PDA

View Full Version : Check engine light



Moomba360
05-23-2008, 09:43 PM
I have a new 2007 Moomba Outback direct drive with the 325 assault EFI. I put the boat in last week for the first time, .2 hrs on it, and the check engine light was on from the start. Oil pressure was good, engine temp was right around 140, and transmission had fluid in it and motor sounded good. Any ideas why the check engine light would come on from the start on a brand new boat? One service tech. stated that the motor has to warm up to operating temp., around 140, then cool down three times for the temp gauge to set itself and then the light might go off. Anyone heard of that? Any insight on this would be helpful and thanks in advance for your time.

TL7
05-25-2008, 07:35 PM
I can't confirm or deny what you were told, but I can tell you that since last year when we bought ours (07 Outback) the check engine light has never been on while running. I would definitely contact your dealer, for peace of mind if nothing else. Good luck and hope everything goes ok!

04OUTBACK
05-26-2008, 01:56 PM
3 Complete cycles will remove the light IF there are no further issues. If it came on for some unknown/no trouble issues... you crank it, run it to operating temp, turn off, allow to cool completely. repeat 2 more times. After the 3rd cycle WITHOUT a fault, the computer will reset... otherwise, they have to connect the computer to it to remove the fault...

Moomba360
05-27-2008, 01:38 AM
A thanks to TL4 and 04OUTBACK for the info. I tried the 3 cycles and the light still is on. Looks like she's going back to the shop, and the weather is just starting to get nice.... Dam it!

Moomba360

jmvotto
05-27-2008, 09:45 AM
Our OBV 07 seems to have the same prob. put three hours on it this weekend we got it with seven, now has 10. Had a great day sunday. I unhooked the battery for two hours to see if it would reset. I will try the three cycles out. i assume temp needs to hit 160 each time.


Anyone know ifs owners can get there hands on the indamar diagnostic software. ( or is that just foolish) i am not really interested in hauling the boat out of the hoist and making the three hours trip.

Moomba 360 let me know how you make out at the dealer.

moomba_armada
05-27-2008, 04:26 PM
Jm, I asked Indmar last year for that diagnose tool, since there isnīt an Indmar service here...had no response about it. I asume they donīt feel ok sharing that with a not official dealer or private person.
I just had the engine working for a while..till i noticed the shaft seal leak, but i think the light was on all the time.maybe that happened because the batteries cables were unhooked during winter.Will try the 3 cycles thing...

jmvotto
05-27-2008, 04:46 PM
Armada,
I found the software on the net but it runs from $600.00 to $2,000 depending on the version. But I would Probably screw EVERYTHING up on the boat.

http://www.obd2allinone.com/sc/toplevel.asp?cat=32

I do have a local local (non dealer) indmar tech near me but his CPU is down and won't be back for a couple weeks. can't wait that long North east season is short enough

I sent the cycle ? to engine Nut to see if that should work, My dealer had never heard of that sequence

i'll post when i get feedback.

jmvotto
05-28-2008, 06:09 PM
Larry, Engine nut need help?

is there a cycle reset for a sequence of warm ups for the check engine light.

joe

Moomba360
05-28-2008, 11:58 PM
jmvotto, I took my boat back to the dealer and here is what they found. The battery cables were connected to the battery while the battery switch was in the ON position sending a so called problem to the computer lighting up the check engine light. Service tech. states when reconnecting cables, lets say for the first time after being winterized, make sure the battery switch is in the off position or hook up the - then the +. The tech. also states 80 to 90% of the boats he sees with a check engine light on is just this case and there is no real problem. It was a five min. fix and there was no charge.

Hope this helps, and let me know if you have any more questions.

Moomba 360

jmvotto
05-29-2008, 07:05 AM
Moomba 360
Battery Switch? On the dash or near the battery or the perko. I don't believe i have any of those. I tried taking the Neg off the battery for an hour and it did not work, reset that is Maybe I will try the both cables off and try and find the switch. Do you have pics of the switch you ar speaking of ?

Glad your boat is fine with no major problems.

JV

Moomba360
05-29-2008, 12:32 PM
Jmvotto,
Not sure about the location of the battery switch, the tech. did not go into any detail. Also, I don't know if you need a service tech. with a computer to clear the code and turn the check engine light off, or if you disconnect your battery and then reconnect with switch in the off postion if that will clear the code? When reconnecting battery try connecting the negative first then the positive, the tech. said this is another way around it.

I'll get ahold of the dealer tech. today to find the location of battery switch and to see if you can clear the code without having to take your boat in.

Stay tuned for more info.
Moomba360

jmvotto
05-29-2008, 05:15 PM
thanks, look forward to it.

JV

Moomba360
05-29-2008, 08:16 PM
jmvotto,
The battery switch should be mounted close to your main battery, at least this is what the service tech. is saying, I have not had the time yet to look for mine. The switch will have a red reset button and a small black lever to turn on and off the battery power to the boat. Now this is for a single stock battery system not a dual battery system, not sure if that is different. As far a resetting the check engine light, that needs to be done with the computer. Again its a quick easy fix but inconvient because you have to take your boat in to a tech.

Hope this helps, keep me posted.
Thanks
Moomba360

jmvotto
05-29-2008, 10:59 PM
Yep, I will try that. I hope it clears the light, but your tech says otherwise. I guess if it does not clear it the boat will be on the trailer sunday night. $%@#

LOL

Thanks for all the info. I will let you know.

jmvotto
05-31-2008, 07:24 PM
Moomba 360,

thanks for all your help. I did what you said, and found the breaker switch to the accessory. panel. worked like a charm, light went off. I will run on sunday again, weather permitting to re-verify.

Few.....

Moomba360
06-05-2008, 11:50 PM
JV,

Glad to hear it reset without having to take your boat into the dealer. Keep me posted after your ride on Sunday. I'll be taking mine out this weekend for the first time after the light was turned off by the tech. Hope it stays off...

Moomba360

jmvotto
06-06-2008, 07:12 AM
Moomba360,

I hope so too, My dealer tech told me they have had lots of check engine light conf calls about low battery levels, most likely when they get it out from winter storage and complete the charge up,and forget the dash breaker/switch. Next sat i have the first 10-20 hrs oil change ( not at the dealer) but at a local Indmar service tech. Hope they don't have the same prob Z did with the oil filter.That is just too much....

Thanks

JV

zegm
06-10-2008, 07:54 AM
JMV

Yeah I am still waiting to see what will happen with the boat. Should find out something today. But it looks like we will be without the boat for another weekend.

jmvotto
06-11-2008, 11:20 PM
i hope you get this nightmare behind you...and your back boating soon.

JV