PDA

View Full Version : Heater Leak?



volfo
05-26-2008, 05:52 PM
I noticed a leak in the boat this weekend. IT comes under the driver "pod" from not far from the heater, and then flows all the way down the driver side of the boat. The water feels good and warm. I believe it is from the heater.

Not sure how it happened as the boat was winterized, and then also kept in a garage all winter where the temperature never got below about 55. In any event, I took out the heater to look at it and noticed that one of the hoses had a small hole in it, about the size a writing pen would poke through. I thought that was the problem, cut the end off the hose and rehooked it up, thought it was all fixed, but the next day we went out and I'm still getting water.

Has anyone else had this problem? Assuming when I take it back apart I don't find that I failed to clamp the hose on tight enough, does anyone know where to get a new heater? It's a 2001 Outback LS. If I had the heater, I could pull it out, bolt the new one on, and reinstall it in about 45 minutes or less I would think.

BLKOUTLS
05-26-2008, 07:27 PM
volfo

double check you connection at the heater again. My 02 connections are at a sevre angle
and getting them to set just right and clamp without any leaks was a little tricky. I thought the core had failed after I had to remove them to replace my steering cable at the beginning of last season.

Chris

zabooda
05-26-2008, 09:45 PM
I've replaced a heater core a few years back. The core leaked and water was on the floor around the drivers feet. Check the connections first then the core. I had a small pinhole leak about 1/3 of the way up the core. Heatercraft sells replacement cores.