PDA

View Full Version : Kind of peeved at SC!!



Geoffrey18
05-27-2008, 05:20 PM
Well I called my dealer today about my PP not working and they told me to bring it in and let them look at it. I have done this today but my warranty is up and I cannot afford to spend alot of money fixing my PP. It is pretty bad when you pay so 30,000+ on a brand new boat and only get a 1 yr warranty. I mean my boat is an 06 purchased in Aug of 06,,so that makes it roughly a yr and a half old. It only has 35 hrs on it to. What a crappy warranty. I mean geez,,my $100 microwave has a 2 yr/3yr limited. What the freakin A. Sorry,,just needed to vent.

Sled491
05-27-2008, 10:09 PM
That really sucks, not to add insult to injury but in 07 they offered a 3 yr warrenty and for 08 I believe they went with a 4 yr. Sorry dude:(

cptmoomba
05-27-2008, 10:13 PM
Another option if your dealer won't take care of you is to call perfect pass directly. Their phone number is on their site. I installed PP after market on my previous Moomba and the guys from PP helped me install it over the phone.

Just an alternative suggestion that I hope works for you.

Membrain
05-27-2008, 10:13 PM
Our boat is brand-new and the PP is trash! I have to get a whole new module. Normally, PPís are bullet proof, but maybe these things are being outsourced to India or something!?

Sled491
05-27-2008, 10:43 PM
You know Membrain might have someting there. Yesterday while out for the afternoon I had the system screen up to watch the water temp between the lake and the river. Well when we got to the bay we wanted to anchor in you couldn't read the screen it was black. I turned the boat off and on again and it cleared itself up, but we have had to go the dealer twice for PP issues in the past. Not really impressed so far with PP. Hopefully one of there peeps is watching this board so they can chime in. PP is supposed to make my life easier not a pain in the A%$!

Membrain
05-27-2008, 10:52 PM
Mine blanks out as well! I have always had this high-pitched alarm coming from the PP regardless of whether or not it is even turned on that WILL NOT shut up! I swore I was going to rip that d@#N thing out and through it across the lake! I have to reach up under the dash and pull and shake the wires coming from the module to get the thing to shut up!

Membrain
06-04-2008, 01:06 AM
Maybe he is from India too

Membrain
06-04-2008, 01:09 AM
Our new module is in, but we donít want to take the boat in to get it installed to miss a weekend! What a dilemma!!!!! I think Moomba should be held responsible!!!!!!!!!!!!!!!

Or at least those little guys from India!

yearround
06-04-2008, 01:15 PM
our screen has blacked out a time or two also. it has always corrected after turning the boat off.