PDA

View Full Version : Where is my fuse panel????



Hillbilly
07-17-2008, 01:25 AM
I looked under my dash for it and did not see it? I have an 07 LSV and my front ballast pump is not working. I pulled the pump out and ran power to it and it works and the switch lights up. But nothing to the pump when I flip the switch either way. I just got the boat 3 weeks ago and I'm learning as I go.

Thanks Hillbilly:confused:

Buttafewcoe
07-17-2008, 04:47 AM
Me OB doesn't have fuses, it's got breakers for the stuff. Did you try resetting them (it)? If so, sounds like a wire's loose.

BensonWdby
07-17-2008, 12:56 PM
My 99 Mobius only has breakers as well. They are under little black rubber 'nipples' on the dash above the related rocker switches.

Razzman
07-17-2008, 02:26 PM
Lay on your back underneath and look up at a large horizontal support to the right of the steering wheel as your looking up. You'll see a small fuse panel with ATO fuses in it for the ballast pumps.

Hillbilly
07-18-2008, 12:18 AM
Found it....Loose wire....Thanks a bunch guy's

gf5300
05-30-2009, 08:48 PM
I have looked and looked and can not find this fuse box. I have followed the all the way where they go back inside the boat with no joy.
I would seriously appreciate if anybody could steer me the right way to find this fuse panel.
Is it an actual panel or is it a fuse container attached to the actual wires?
The boat: an 05 LSV with gravity I installed.
Thanks.
By the way, all my switches have breakers. Could it be that there is no fuse panel?

Razzman
05-31-2009, 01:15 PM
I can't speak for an '06 as i've never looked at one but i can't imagine it being different. See my post above, it's a small fuse block about 4x6" way up under the dash attached to a dash support, it uses mini fuses if i remember right.