PDA

View Full Version : runnin' hot



Cheymoomba
07-28-2008, 09:26 PM
I ran my 2005 Outback for about four hours this morning, docked for lunch, then it started overheating as soon as i left the dock. When I tried to take off it had little power, and the temp guage spiked. I am 5 hours from home with two more lake days to go. The boat guys are backed up for weeks and I need a quick fix. Please help!

AaronWhitt82
07-28-2008, 10:45 PM
As far as your overheating probs I would say you need a new Impeller (Johnson 812B) or your raw water pump took a crap.
The power issue could be a number of things... Make sure your getting enough fuel, possibly vapor lock? IS your boat carbed? Could be problems with the carb. Need a little more info on how its acting to better diagnose it.

Waynes345
07-29-2008, 12:13 PM
Make sure it's not the gauge first. I had the same problem and replaced impellar and thermostat before tapping the gauge and it settled back to where it was supposed to.

byronkoz
07-29-2008, 06:27 PM
I would be very carefull. If your motor is over heating that could cause a lack of power.

Sled491
07-29-2008, 09:45 PM
I agree with the impellor diagnosis. Seems like your overheating would be the cause and symptom.

zegm
07-30-2008, 02:35 PM
I overheated our old MC in the past, didn't know that we were not getting water to cool the engine and exhaust. We ordered the 2008 LS and I also ordered the "water strainer". This is a Great option and one that could be easily refitted on any of these boats. It is just a big filter with a screen that is easily removable to clear out weeds and other debris. What I really like is the large bowl is CLEAR PLASTIC, now we see we have water flowing whenever I pick up the engine cover. This part could not cost more than 50 to 75 bucks and all it takes is a knife to cut the incoming water hose and a pair of hose clamps.