PDA

View Full Version : Tower speakers stopped working



ottawarider
09-11-2008, 07:35 PM
Has anyone had this problem at all? I got swamped by a 50 foot sea ray and i think the problem may have started then. I have the two speaker setup on a 2007 outback v. Thanks!

jester
09-11-2008, 11:27 PM
Do you have an amp for the tower speakers? If so have you checked the power light to make sure the amp is getting power?

bergermaister
09-12-2008, 02:01 AM
Definitely check out all the fuses or breakers on the deck and amp(s). Sometimes (hopefully) it's the simple little things.

ottawarider
09-15-2008, 01:31 PM
alright thanks going to go check those things out now!

ottawarider
09-15-2008, 02:53 PM
alright so i have an amp that seems to power the tower speakers but woudnt the amp aso power the rest of the speakers in the boat (the rest of the speakers are working perfecty) i tried connecting the tower speakers to a boombox and it resuted in no sound. Just trying to find a solution other than driving 3 hours to the dealer!

zabooda
09-15-2008, 04:45 PM
Check the conductivity of the speaker wires. Remove the wires from the speaker and the amp, connect the speaker wires to the amp together and put a ohmmeter to the speaker wires and see if you a complete circuit. Also, check the tower speakers and amp by running speaker wire from the tower wires to a speaker that does work. Check the input to the amp by connecting a boombox output to the input of the amp.

You just have to go through steps to rule out certain components. Since both speakers are out, I would guess that it is the amp or the stereo that supplies the signal to the amp.

Buttafewcoe
09-15-2008, 07:25 PM
If they are on a channel by themselves, it could be something wrong there. I've blown channels w/o damaging the entire amp.
.
B

lowdrag
09-17-2008, 08:42 AM
alright so i have an amp that seems to power the tower speakers but woudnt the amp aso power the rest of the speakers in the boat (the rest of the speakers are working perfecty) i tried connecting the tower speakers to a boombox and it resuted in no sound. Just trying to find a solution other than driving 3 hours to the dealer!

It depends on what amp you have. A lot of the boats are wired with a 2 channel amp that only runs the tower speakers. The rest of the interior speakers would be wired to the head unit. Another option would be to check the settings on your head unit to make sure something hasn't changed. If I remember correctly I believe that there are options that control the output to the amplifier.

ottawarider
09-18-2008, 07:20 PM
alright thanks for all the help! turns out it was a blown fuse in the amp and ya the amp only powers the tower speakers... I didn't realize that a regular stereo wouldnt power the tower speakers. Thanks again saved the rest of the summer for me!