PDA

View Full Version : Speedometer and heater problems



jamesroger
10-16-2008, 08:37 PM
I just bought an '03 outback and having some troubles with the speedometer and the heater. These problems are the speedometers do not move when the boat is moving and the other is when I go to turn the heater on the breaker immediatly flips, the heater doesn't even fire up.

For the speedometers could the knobs on the dash be the culprit? and for the heater any ideas? was thinking it could be a fuse but have no idea where to look for it.... Any ideas would be appreciated! still pretty rookie at this boat owner stuff...
Thanks;
James

zegm
10-16-2008, 08:46 PM
Speedo,
Do you know if you have a pitot tube type or a paddlewheel type? A clogged pitot tube will stop that type and a bad paddle wheel could cause issues there. Do a search on this site for these issues.

Heaters, boats, sorry that one is foreign to me? But basing this on a car type system there is going to be a valve that allows hot water from the engine to circulate through a heater core and then there is going to be an electric fan to move air across the heater core. If there is no air coming from the ducks then I would suspect:
1. blown fuse
2. bad/stuck electric motor

RobertJ
10-16-2008, 08:50 PM
I am also a rookie, but I would gues of both speedo's are not working it is either the paddle wheel has something making it stick or the wiring from the paddle wheel to the speedo's is messed up.

I would get under the boat with a flashlight and inspect the paddle wheel and see if you can make it spin. You might be able to make it spin with air and you could have some one check to see if the speedo's show anything. I bet the key will need to be on for this to work.

P.S. don't hurt yourself or force the wheel to spin if it seems stuck.

BensonWdby
10-16-2008, 11:09 PM
If the other gauges are having issues it might be the controller.