PDA

View Full Version : truck gurus mechanics



jmvotto
10-19-2008, 09:37 PM
I have an 03 Chevy suburban with 95k on it. Brought the moomba home about 60 miles today to take to the dealer on tuesday. get boat home no problem using the tow switch. I unhook the boat and run an errand . the Burb now slips at 25 mph to from abou 2000 rpms to 4000 rpms. i ease of on the gas and travels ok at 25 to 30. give it power, high rpms and no response.

Any thoughts. i will be taking to the shop in the morning, hopefully will be up and running for tuesday.. I don't believe it is the serpentine belt.?

thanks for any thoughts in advance.

02tahoeindiana
10-19-2008, 09:42 PM
Sounds like its still in Tow/Haul mode? Is it slipping or just down shifting?

jmvotto
10-19-2008, 09:56 PM
Its slipping, i tested the switch off and on and it adjusts properly.:confused:

02tahoeindiana
10-19-2008, 10:10 PM
Hmmm? not sure. Tranny Slipping? :confused:

jmvotto
10-19-2008, 10:20 PM
I know not good. Going to Michigan on thursday as well.:mad:

02tahoeindiana
10-19-2008, 10:25 PM
Ya. but i would be suprised if its something that major unless you tow alot, or beat the sh*t out of that Burb. I have and 02 Tahoe with 140,000 miles and never had a major problem. Most of the other people i know with Tahoes or burbs havent either.

jmvotto
10-19-2008, 10:37 PM
thanks, i hope not. I tow the moomba 2x a year. the rest is small lawn tractor stuff infrequently.

02tahoeindiana
10-19-2008, 10:43 PM
Ya then i cant really see anything major going wrong.
But who knows just one faulty part can ruin everything

Sled491
10-20-2008, 12:04 AM
Wouldn't hurt to get the tranny fluid changed just in case. I lost a gear this summer on my Diesel. Drove for a month before I finally lost the speedo as well. So I took it in. Speedo was a wheel sensor and the second gear belt snapped. Instead of a 1500.00 tranny rebuild, I got away with them slipping a new belt in for about 150.00. They told me that they had a 80% sucess rate with just the new belt. So far I have had no problems, including a trip to Canada and back for a fishing trip.

jmvotto
10-20-2008, 09:07 AM
sled, thanks that helps I hope i don't need a 1500 rebuild. I was able to get the truck to the service station this am and i should know by noon.

maxpower220
10-20-2008, 09:15 AM
First, do what is easy and check the transmission fluid level. You need to have the truck up to temp and it should be running in Park to get an accurate reading. If you have an AutoZone nearby, they will let you use their ODB scanner. This may show a "code" if the problem is an electrical glitch in the tranny.

jmvotto
10-20-2008, 10:45 AM
I got the report from the service station its 3rd gear. Hopefully we can get away with a belt and if not looks like the 1500 its at the dealer now.:(

kaneboats
10-20-2008, 12:05 PM
Got the '01 Burb with 83k on it. Think I'll add tranny service to my list of "to do" stuff this month.

Sled491
10-20-2008, 01:15 PM
See the difference for mine is the second gear just stopped working, I never had slippage. Also with it being second gear and a high torque diesel I could just get the tranny to jump second and go straight to third, even pulling the boat.

Hope they can go the cheap way, especially in these times!

jmvotto
10-20-2008, 05:46 PM
stock Market is up and the tranny is out. just like the BoSox

Third is gone and 2nd is 95% there. New tranny time 1900 plus labor and fluids $%#@#.

Moomba For sale, cash Only JK

Looks like I am keeping this for a while.

Kane good Idea get it checked while it still works.

:sad:

SEARK
10-20-2008, 06:24 PM
Got the '01 Burb with 83k on it. Think I'll add tranny service to my list of "to do" stuff this month.

Had an 01 burb, would burn 2 quarts of oil pulling anything. Tranny actually fell out while I was pulling into the shop to have it checked. Use a Tundra now.

kaneboats
10-21-2008, 12:42 PM
My Mustang had about 94k on it and was hunting between 2nd and 3rd all the time. I disconnected a trans. line at the radiator and pumped all the fluid out I could get. I dropped the pan, emptied it and cleaned it. I put it back and did it all again. Then I changed the filter and topped off. Problem fixed and no problems with it since.

Any transmisison guy will tell you it's the most neglected part of a vehicle. People that religiously change the oil will ignore the transmission service schedule. When you do get it changed you only actually remove about 1/3 of the fluid. So you never actually get all the old fluid out unless you flush. I don't want to start a debate about whether flushing is a good thing or causes damage to seals, etc. For me, the safest thing to do is put all the clean fluid in that you can and then try to keep it clean. If you do this and keep it from getting hot it should last a long time.

Sled491
10-21-2008, 07:53 PM
I slipped in the shower last week, does this count as 1st hand experience?