PDA

View Full Version : 09 Perfect Pass Install



SouthSideWakeboarding
01-03-2009, 08:46 AM
Hey guys..

Just got PP for my 09 LSV.. On the wire cluster that goes from the display unit to the DBW Master Control Module there are 3 loose smaller plugs 2 with 3 wires into a plug labeled timer and 1 with 2 wires into plug labeled switch? Does anyone know where these are supposed to plug in? Can easily see the how others plug in but can't work these out.. Thank you for any help..

Cheers..

Jon
01-03-2009, 03:26 PM
Pretty sure they are for the timing magnets for Digital Pro. See here: http://www.perfectpass.com/pp_support_usersmanual.html . Click on Digital pro and go to page 23

SouthSideWakeboarding
01-04-2009, 05:19 AM
Thanks Jon.. I was thinking along those lines but thought I would put it out there.. Installed the PP after work today and tested it out.. Works great.. Very easy install in the end.. Just a few plugs.. Cheers.. Thanks for the help..

tazz3069
01-05-2009, 06:35 PM
Dumb question. Have you tested it on the water yet. The cluster that went to the back of the speedo, on mine does not get connected to the New PP Guage. When I did this, and tested on the water, I could not set the speed. When I got under the dash to make sure everything was wired right, I found another cluster of wires with the same connector on it. I unplugged the first cluster and pluged in the one I found. It works awesome now. I found this other cluster on the very top of all the wires tied up with a zip tie. You might want to check this out.
Tazz

SouthSideWakeboarding
01-10-2009, 06:31 AM
Hey mate..

Yep the Moomba cruise had only one of those plugs plugged in.. The PP used an additional one that wasn't plugged into anything previously..