PDA

View Full Version : Speedometer - Please help



jamesroger
04-10-2009, 09:39 PM
Hey;
Well I finally was able to pull the boat out of storage and start on some modifications and repairs. I just bought the boat last year and the spedometers didn't work. I asked the guy I bought it from about it and he said it was just the knobs on the dash. But when I pulled it out this year, tried to get some movement but still nothing (moving knobs). All my other gauges work. Any ideas? Could it be a fuse that has gone or something? Thanks for any help!!
James

dtlaine
04-10-2009, 11:44 PM
What year? If it's newer w/ a paddle wheel, be sure it spins freely. If it's older with the pitot pick-ups, be sure they're free of debris. I had a 2000 OB LS, and the electronic box in the back of the boat had issues from time to time. I'd just unplug it, plug it back in, and it would work for a while again. I hope that helps.

jamesroger
04-11-2009, 12:11 AM
The boat is an '03 and has the paddle wheel. When I was out trying to get it to work put the battery in turned on the egnition, just to the run position, and blew air accross the paddle wheel. It had no troubles spinning and has no visible damage to it.

jamesroger
04-11-2009, 12:25 PM
Thanks for the info. Will have to wait to get back at it once it warms up a little more, don't have the luxury of the big heated garage...yet:( Kinda new to the game so could it be the paddle wheel itself? or do they have a pretty good track life? and one more thing is there a fuse that could be out?
Thanks again for the help;
James

BensonWdby
04-12-2009, 01:46 AM
Do any other gauges have problems? My 98 Mobius had issues with speedos and it turned out to be the gauge countroller - the 'brain' for all the gauges. Apparently it can get moisture in it and when it freezes if cann crack the transducer housing and flood the box. I have replaced one controller already. Am worried about it again this year. I meant to bring it in over the winter, but forgot to..

jamesroger
04-12-2009, 05:01 PM
No problems on any other gauges. They all seem to be working perfectly. Just the two speedometers, are the ones that are having the troubles...