PDA

View Full Version : The Noise :(



insanepolack
06-22-2009, 07:33 PM
I posted before on this subject but still have not fixed the problem:mad:

I have that annoying buzzing noise that happens when I turn on the engine and blower.

My setup is a brand new expensive pioneer deck, clarion 720 watt amp, and six polk momos.

I have already fixed the common problems that create this noise... all the grounds are perfect and to the same spot. RCAs are not close to the power wires at all. I even wired the head unit to the battery with its own switch but still get feed back. My battery is fully charged.

I tried some cheap ground loop isolators but they completely destroyed my sound quality so I returned them right away.

So are there any methods that I can try? Will high quality ground loop isolators affect sound quality?

zabooda
06-22-2009, 09:05 PM
If the interference is coming through the power source then you need a filter. A pi filter should work.

http://www.radio-electronics.com/info/circuits/lc_lowpassfilter/lc_lpf.php

insanepolack
06-23-2009, 12:34 AM
Does anyone have one of these? Where do you put it?

jjolson
06-24-2009, 12:36 AM
It is in the stereo switch. The only way that i have gotten this sound to go away is by bypassing the switch entirely. The ground loop isolator only reduced the sound but did not eliminate it for me. I do not have the cables by power wires either.

insanepolack
06-24-2009, 09:59 PM
It is in the stereo switch. The only way that i have gotten this sound to go away is by bypassing the switch entirely. The ground loop isolator only reduced the sound but did not eliminate it for me. I do not have the cables by power wires either.

I tried bypassing the switch but still got the sound.:confused:

mmandley
06-25-2009, 10:42 AM
Have you bypassed the Clarion amp to see if you still get the noise? Hook it right to the HU and see if the buzzing is there. If it is then it might be a bad internal ground in your HU. If its not then its the Clarion amp with a bad internal ground.

Lots of mentions in past posts about Clarion amps having this issue. Not putting your amp down i have no issues with it, just forwarding info i read here.