PDA

View Full Version : 2004 LSV Cover - Strange Config



Shoemaker Mobius
03-29-2004, 11:24 AM
We have a 2004 Mobius LSV with a cover that we store outside. Since this is our first boat, we were concerned about whether the cover would be difficult to put on and take off. We have found it is fairly easy to put on, but I question the configuration of the poles that go into the sleeves in the cover. The sleeve in the front of the boat seems postioned well and we don't get any rain water pooling up front. But, the two sleeves/poles that go toward the rear of the boat seem to be positioned very poorly. While we don't get rain water pooling to the rear of the poles, we get a significant pool of rainwater in front of the poles, between the poles and the windshield area. In my mind, I would have thought the two poles should have been positioned down the center of the boat so it would form a highpoint in the middle so rainwater would just run off. Putting them on the port and starboard positions is worthless. Can anyone at Moomba please explain how we can rectify this? Can sleeves be put down the middle? The rainwater pooling is so large that I have to use the pump from our fat sacs to pump it out and unless I get to it immediately after a rain, it pools and leaks thru the cover, soaking the carpeting on the boat. Anyone else see this problem??

Jon
03-29-2004, 11:47 AM
We have the same problem with the LSV on our lot. We just put one center pole ,extended pretty high, in between the ski pylon and the windshield. No sleeve but it works.

Shoemaker Mobius
03-30-2004, 09:01 AM
Thanks for the responses. I decided to try just positioning the two rear poles down the center of the boat, positioned on some overlapped seams in the cover. So far so good, but no rain yet. But, I don't see any areas that should pool (other than two small areas where the pole sleeves are). What I don't understand and would like Moomba to address is what logic they had for putting the two sleeves in the rear where they are. Hey Moomba, how about someone weighing in on this????

MEDIC151
03-30-2004, 10:21 AM
I had the same problem on my Outback LS. I made a PVC frame with 1/2 pipe that I can put together(no glue). A couple of t's for feet and then ran it up and over the engine cover. It gives enough lift all the way across to shed water in all directions. Cheap and easy.

Medic

waterboy
03-31-2004, 03:50 AM
I did the same with my 2001 Outback. Besides the 2 back poles I just added a piece of PVC pipe (with foam on both ends) right behind the engine box. No more pooling.

Hey Ed....have you tried using Damp Rid inside your boat to help with the mildew problem? Have you been skiing lately?

Brian

waterboy
03-31-2004, 03:50 PM
Maybe for your set up it might not work too good. I know that you don't have a shelter for your boat, but have you thought of adding a plastic tarp over the regular cover? I use one on mine just to keep out the dust that gets in through the breathable fabric of the cover. My crummy homemade boathouse isn't completely watertight either, and the tarp makes all the difference. So with a set up like mine where the cover doesn't get too wet the Damp Rid works great.

I'd be happy to teach your wife to wakeboard. We should disuss it over dinner....Do you ever go to Thai Lotus?

Brian

waterboy
04-08-2004, 05:00 AM
Ed,
Thai Lotus is on 50 about a mile past the old Scotty's.....try it sometime, the food is great. Have you been to the Tikki Lounge behind the Minneola Inn? You can dock your boat out front, they're right on the water. We've taken our boat all the way through the chain to get there, with no problems.

Mary Ellen and I still have the wacky schedule, with Weds. and Thursdays off, and Monday and Tuesday afternoons free. What's your schedule like these days? We should all get together now that the water is warmer, maybe Mary Ellen and I could take a weekend day off. How crowded is Lake Louisa on the weekend?

Maybe we should invite Gordon up to check out our lakes?

Brian

waterboy
04-09-2004, 04:45 AM
Over the next couple of weeks we have family coming to town (cold and crabby New Yorkers :p ) and then we'll be free, so I'll shoot you an email.....

Mary Ellen and I can both swing a Friday off, so if you can play hooky that day we'll have the lake to ourselves!

Brian

Shoemaker Mobius
04-13-2004, 02:54 PM
I spoke with a technical rep from Skier's Choice about the sleeve positions. He claimed that they are positioned correctly, but people tend to raise the poles much too high. He indicated that they should be just barely above the tow pole. He also said you did not have to remove the seats to position them. Based on his information, I went and tried to set it up the way he said. However, it just won't work that way. I am now using the two poles straight down the middle of the boat, with a tennis ball on the top end, one pole just behind the windshield, positioned slightly higher than the windshield; the second pole just in front of the rear seat at a height that forms a straight downward projection from the first pole to the second pole to the tow pole. We had a huge storm with much rain and this setup worked perfectly.

moombaschleg
08-03-2004, 09:30 PM
Hey all. Glad to hear I am not the only fool who has issues with the factory cover!

I do like how it is easy to install, but puddles. We have an '03 Outback LS. If I had it to do over, I would have skipped the factory cover, and had one made....One with vents, to help with the mildew problem. The storage area in the back is impossible to keep dry, even since we have stopped putting wet things in there (even though this is obviously the most convenient place to put things as you get out of the water). The ski locker holds water, since the drain is not placed appropriately....anything we leave in there gets covered with mildew.

Unfortunately, we cannot leave our boat open in the hot sun to let it dry before we put it away. We have to cover it, and put it in the garage with wet carpet at times, which doesn't help with the moisture issue. I use damp rid, which helps, but I know we did not have these problems with moisture with our '94 i/o with custom cover (with vents).

I WOULD BE VVVEEEERRRRRYYYYY INTERESTED IN SEEING PICTURES OF THE PVC FRAMES YOU ALL HAVE BUILT!!!!

Thanks!

Wes

gulllakewake
08-15-2004, 10:36 AM
We have an 04 LSV, and rarely use the poles, I put a tube in the bow, stand another up near the walk thru and have no problems at all, also no fiddling around with poles in the near dark. I might get some bashing about the tubes but the kids like em and now they have two purposes

lowdrag
08-16-2004, 12:40 AM
I had the same problem with my Mobius LS. I bought a cover support from Overton's. Search for item 35066 on their site. It has a nylon strap that wraps around the bow and attaches to the eyelets in the stern. There is a telescoping pole and plate that the straps attach to in the center. No water problems since and it's just about as easy to set up as getting the poles positioned under the cover and getting them to stay standing while you put the cover on.