PDA

View Full Version : Impeller housing



ben624
07-08-2009, 12:08 PM
Has anyone every replaced the bearings in the impeller housing? The bearing is leaking out the back of the housing. So before I pull the housing with a bearing puller. And replace it. I was just wanting to double check to make sure that is how I take off the housing to get to the bearing. Thanks for any and all your help.
Ben

K_E_N
07-08-2009, 03:54 PM
I don't completely understand what you're asking. With my boat, '04 LSV, I took the hoses off, removed the bolts that connect it to the crank shaft, and removed it from the boat. There's a bolt on the bottom of the housing, but mine was broken.
As far as replacing the bearings, I've heard that you can rebuild this with new bearings and seals, but I just replaced the whole unit (along with the broken bolt). Purchased it from skidim for around $200.

ben624
07-08-2009, 06:54 PM
Thanks... I have a 99 outback... So I think it is a little different... What I am thinking is the housing and bearing are sealed and pressed on the crank shaft... If i can get it off without breaking it.. I will order a bearing and seal for it... Maybe it will be a little less expensive.. But who knows with baot parts... If anyone else has any info please let me know..Thanks for your help.
Ben

jsol_way
07-13-2009, 11:11 AM
I have a 98' Kanga, and have just recently replaced the impeller housing due to it leaking out the back where the bearing was located. I'm not sure if you can replace the bearing and seal...I don't see why not, although I bought the entire replacement part for about $230 through a dealer. The pump is bolted to the harmonic balancer with three bolts (actually quite stubborn bolts as I remember), shouldn't require a bearing puller until you actually remove the pump housing from the balancer. Rebuilding the pump might be a good idea due to the fact that my new housing didn't quite bolt up true which caused some serious vibration. Ultimately I ended up drilling out the mounting holes in order to fit the brass alignment rings that were utilized with the old pump mounting holes. This seemed to alleviate the vibration and it seems to be working fine. So basically, to make a long story short...pull the three bolts and rebuild or toss the old housing; bolt up the rebuilt/new housing and you should be under way.

ben624
07-13-2009, 11:47 AM
Yeah I fiqured out how to take it off... I even found the bearings at NAPA... But the seal is a whole different story... The bearings were $10 doallors a piece... Everywhere I called they all said the same thing... They don't sale parts to fix them.. Only new housings... What is going on here... It should cost no more than $30 dollars to repair the pump... But I guess they think everyone are just parts changers... So I used a mic and order a seal from the meausurements... It will be here tomorrow... I hope it will fit and work.. If not skidim and $230 dollars here I come... Will keep you posted on the seal if anyone cares to know if this is going to work... Thanks for all your help and info.
Ben