PDA

View Full Version : Ballast pumps hard time filling



kfechner
07-16-2009, 08:14 PM
Every time (I mean every weekend) I head up to the lake...I fill up my sacs immediately and it take a long time for water to start filling the sacs. The pumps are on when I hit the switches, but the water takes more than a few minutes before it starts pumping. I read something on how I need to "prime" the pumps. What does this mean? Or...could I have a clog and it just takes time? After they start to work...it fills very fast and I have never had an emptying issue!

Kelsey
07-16-2009, 08:34 PM
try getting up some speed first, then flip on the switches. Works for me.

cab13367
07-16-2009, 10:21 PM
Yup, get your boat up plane then hit the fill switch. This forces water into the intake and to the pump so that it can start pumping water. Otherwise, it is trying to pump air.

Wake Master
07-16-2009, 10:38 PM
If you have a filter on the ballast system simply unscrew the filter, empty the water, put the filter back on, turn on the pump and they will fill.

kfechner
07-17-2009, 01:01 PM
Wow...thank you! I am heading out this afternoon and will give it a shot...I have always tried filling at complete stop. I will let you know.

bjames
07-17-2009, 01:39 PM
How fast do you go when filling the tanks? Also is it better to travel while emptying or is it best to be stationary?

cab13367
07-17-2009, 04:21 PM
How fast do you go when filling the tanks? Also is it better to travel while emptying or is it best to be stationary?

I go about 20 or so before I hit the fill switch the first time. After that, you can fill at any time.

Doesn't matter if you are traveling or adrift when emptying. However, if I empty the bags while adrift, I usually hit the empty switch again when I am moving because the nose up attitude of the boat forces more water towards the back of the bags and the pumps can pump it out. I just keep a close watch on the outlet and shut it off once no more water is coming out.

cab13367
07-17-2009, 04:22 PM
Oops, sorry, I see that you have an 09 which has a different ballast system so you won't see the water coming out of the thru hull fitting since it's below the water line.

kfechner
07-20-2009, 02:31 PM
Thanks for the info guys! I had no more issues filling the sacs while moving....it was so much easier and made life that much better on the water this weekend!