PDA

View Full Version : Reset check engine light???



JUMPSA125
07-26-2009, 07:28 AM
The CEL in my 07 xlv have been on for a few trips...everything seems ok...ie runs goods, gauges check ok. Is there a way to reset it? I tryed disconneting batteries but that did not reset it.

zegm
07-26-2009, 11:53 AM
One simple check is to make sure your oil dipstick is seated all the way in! We had a check engine light on once and that was what created it! We had just checked the oil and didn't push the dipstick in good enough to seal.

Mikey
07-26-2009, 10:12 PM
I recently went through this as well. I was under the understanding it might correct itself after 6-8 full engine hot /cold cycles. Apparently some model have this. My engine light came on at first startup after dewinterizing,and it really bothered me at first as i thought i had done something wrong. After many conversations and inquiries ,i got numerous answers.
I did know my boat was running fine, oil pressure was good ,temp was good etc and no apparent reason. Gas cap was tight , dipstick you name it.
I even had a reply from engine nut,The motor guru.
Only real reply was watch everything and run as is, or PAY and have it read by dealer and have it reset.
It bothered the crap out of me ,and i even considered covering with tape and then low and behold my light went out.
Since then i was asking another dealer tech and he said it mayhave even been a low battery sensor at first fireup even though i charged it up beforehand.

I feel for you and now i still pay particular attention to how she runs but for now All is Good. Hope your luck changes and your light goes off as well.

JUMPSA125
08-02-2009, 07:37 AM
took it out this time and "poof" it was gone.....might have been the low battery....have to make sure its fully charged before i drive it from now on.

Sled491
08-02-2009, 08:21 PM
We had the same thing this beginning of the season, and like most it just went away.