PDA

View Full Version : Water leak



04 Sun Mob LS
04-10-2004, 01:42 PM
Yesterday was our first ime on the water in our 04 mobius ls. After running the boat for a while I checked th engine compartment for leaks etc. I found some water in the bilge area. Not alot but enogh to seek the source. I found water leaking from the solenoid in the ballast system. It is coming from the connection that leads to the rear tank. I shut the master valve off so no more water could enter the system. When I got home I pushed the red sleave back and uncoupled the hose to inspect the connection. I could not find anything visually wrong. I have now reconnected the hose to get ready for our next outing. However, I need to somehow seal the connection better so when I fill the tank up I will not fill the bilge as well. Is there something I can do to better seal this connection so that water doesn't leak out and so I will be able to unhook this fall when winterizing the boat?
Thanks

WisMoomba
04-12-2004, 11:39 AM
We got our 2004 Mobius LS at the end of last year. We had the same problem. I sent it back to the dealer to fix and I haven't seen yet whether or not the fix worked as it is still pretty chilly up here in WI. Our problem seemed to be that the intake tube was too short to adequately tighten. Whatever...I figured the dealer can handle it

Keaton
04-12-2004, 03:06 PM
I used to have the same problems with mine. I have a 03 mob V. I took it into the dealer and they never could duplicate it so they said they couldn't fix it. The problem is were the red sleeve that slides on the quick connect is. It slides back on its own and then the quick connect pops off. Its a poor design. You can do what I did and take a thick rubber band and wrap it in place of the red sleeve and take the red sleeve off. The rubber band wont move and you can still disconnect them when you need to. It never pops off any more. I have another problems now. Where the blue water bed fitting goes on the clear nipple of the bag, it pops off from there. Dont know if its comes unscrewed or if it pulls off from the threads. Don't have a fix for that one yet. Im working on it though.