PDA

View Full Version : fuel problems



jjerrod
08-23-2009, 09:52 PM
Today was my first troubles with my moomba outback DD. It would not stay running unless I manually held the choke closed with my hand. I guess it is starving for fuel. The fuel filter is clear and everything looks ok. Havenít tore into it yet but I thought I would get some opinions before I got to involved

Buttafewcoe
08-24-2009, 11:48 AM
had to replace me low oil pressure safety switch recently because of a similar issue. the engine would run just long enough to suck the gas out the bowl then quit. I checked a couple things and found out the fuel pump wasn't running when the engine was. replaced the switch and viola
.
hope this helps

jjerrod
08-24-2009, 12:50 PM
thanks, I will have to check that out.

Buttafewcoe
08-25-2009, 09:33 AM
keep us posted on yer progress

OldeBoy
08-26-2009, 08:32 PM
I had a similar problem back in May. The connection between the fuel pump and the low oil pressure sensor was faulty. Once I re-wired the connection at the sensor it ran fine.

jjerrod
08-26-2009, 10:48 PM
I decided to first check the fuel pressure by manually unscrewing the hose from the carb and try to start it to see if I had enough fuel pressure. I put the hose in a clear bottle and had excellent fuel pressure when i turned the motor over but the fuel looked horrible and didnít even smell like gas very much. After letting the gas settle in the bottle you could see the separation from gas and water.. Looks like I just had bad gas. I donít know if that explains why it would run only with the choke closed though. It really seemed like a fuel starvation issue instead of a bad gas issue.