PDA

View Full Version : Stereo Controls



Bcoutsfly
08-29-2009, 09:17 PM
Does anyone else have problems with the auxiliary stereo remotes? The remote on the stern always works but the one next to the drivers seat works sometimes. No matter how hard I press the buttons, it just won't work. Any ideas?

moombahighrider
08-30-2009, 04:47 AM
Check the wiring plug behind and make sure that it is not zip tied too tight. That can cause the wire connections to break contact occasionally or all together. Skiers choice installers seem to have a bad habit of being over zealous with the zipties on the wiring.

The remotes are quite simple, just power and ground and then one signal wire to the stereo. Ensure each of these wires is contacting properly.

Let us know if that does not work out for you.

Bcoutsfly
08-31-2009, 01:49 AM
Ok I'll give that a try, it'd be nice to be able to control the stereo for once. I'm sick of my riders always controlling the tunes.

tailgate
08-31-2009, 02:12 PM
I'm having the same issue, and actually took it in to have it looked at under warranty, they did not change it saying I had to push the buttons firmly... whatever...:rolleyes:

The problem is that the crappy remote on there has rubber buttons, and the contact under them don't make contact... They do but you have to really push and feel around for them, not something I want to mess with while I'm trying to mute the stereo while trying to pick up my downed rider...

I'm replacing with the kenwood remotes soon, more tactile, and better quality, now I'm done with my 1 yr warranty/dealer.

Jon
08-31-2009, 03:28 PM
Check with your dealers everyone. There was a recent service advisory about this. Your dealer should have the fix.

jester
08-31-2009, 04:02 PM
Do you know all the boats and years it affects or will affect?

tailgate
08-31-2009, 06:08 PM
Well, like I said, my dealer determined they were not a problem, but probably didn't play with it much to notice the problem. I'm still going to replace mine,

tailgate
09-13-2009, 09:20 PM
Update, replaced the driver remote today with the Kenwood KCA-RC50MR, and what a difference. Every time I hit a button it did what it was supposed to do, the old one would often times do nothing... Easy to install, fite the same holes as the old one, doing the rear remote next...


Well, like I said, my dealer determined they were not a problem, but probably didn't play with it much to notice the problem. I'm still going to replace mine,

you da man
09-13-2009, 09:29 PM
Update, replaced the driver remote today with the Kenwood KCA-RC50MR, and what a difference. Every time I hit a button it did what it was supposed to do, the old one would often times do nothing... Easy to install, fite the same holes as the old one, doing the rear remote next...

And surprisingly a "cheap" mod/upgrade for the boat. Good lookin out for us. Thanks.