PDA

View Full Version : stereo questions amps subwoofers



hyperlite
04-20-2004, 01:06 AM
i just bought my 2002 mobius v and the stereo cuts out completely. come to find out the dealer wired all 10 alpine speakers to the deck and there are also two jl audio subs under the dash. I am wanting to add two amps.. one for the four tower speakers and one for the subs.. do i need another battery for this or what are my options. also am i okay to run the other speakers off the deck.

tygger6069
04-20-2004, 11:10 AM
hyperlite,

I have two amps on my boat, 2000 Kamberra, with no change to the battery. It has been suggested that I put another battery in the boat with an isolater as a precaution. The last thing any of us want is to be dead on the water after chillin' all day with the stereo on. I ran all last year with just one battery and did fine but will do the battery upgrade and get my alternator kicked up alittle higher this year. Hope that you are enjoying your boat as much as we do ours.

hyperlite
04-20-2004, 11:48 AM
How many speakers are you pushing with your amps and how do you determine how much charge the alternator is putting out...

MEDIC151
04-21-2004, 10:48 AM
I run 9 speakers total with one amp and I have all of them into the amp. If you don't wire all of them through the amp, you have no way of reducing the bass to the stock speakers which will cause them to distort easier. I have my 10" sub on one channel and it is the only speaker that handles the bass. All my others are for the mid-range and treble. This setup works great for me and haven't had any problems so far. I did get a second battery and a battery selector switch so that I can have a second for a failsafe. I have a new digital camera on it's way, so once I get it in, I'll take some pics of the setup and post them.

Medic