PDA

View Full Version : Perfect pass alarm



ddufour
09-14-2009, 02:15 PM
Just received a call from my Moomba dealer regarding an audible alarm with my 2008 LSV that I could not figure out. They have informed me that the problem has to do with my perfect pass requiring high voltage vs low voltage at start-up. As the boat is past the one-year warranty, Moomba will not cover the change, so my dealer is checking with Perfect Pass.

I asked if there was a recall, as my dealer indicated this a recurrent problem from Moomba.

Has anyone had experience with this issue? Any advice?

Thanks,
ddufour

squeeg333
09-14-2009, 05:50 PM
Had you been using Perfect Pass before, and the alarm just showed up? I've also got an 08 LSV with Perfect Pass. Just curious if it's something I need to keep an eye on. It works really well right now - boat has about 108 hours on it.

ddufour
09-14-2009, 06:43 PM
Yes, I had been out with the family for over 3.5 hours when it suddening began to alarm. The boat was running when it started, so the idea of a voltage problem at start-up seems a little weird.

Still waiting to hear from my dealer as to what the Perfect Pass people have to say.

ddufour

Mikey
09-14-2009, 09:43 PM
I had to replace my module twice,covered by PP due to Moomba high voltage burning the modules out. No bells,whisles, sirens alarms, just dead screen.Has been good since.

ddufour
09-15-2009, 01:25 AM
Thanks Mikey, I'll make sure to mention that to my dealer.

squeeg333
09-15-2009, 07:52 PM
Bummer news. Sounds like I'll have to keep my eyes and ears open for this problem. Thanks guys.