PDA

View Full Version : Heater install in my '07 LSV



csmsk
04-11-2008, 09:42 PM
Hey guys,

A few of you wanted pixs of the heater installation that I did this winter, so I figured I'd throw 'em in here.

The project took me all day on a Saturday (6 hours, lunch, and a little more than a six pack). The total cost for the heater and all the parts came to about $550, but I used some expensive heater hose (GoodYear Hi-miler.... made in the USA!)

It works great! The Hot-tubes pull out about 6 feet. If you tuck one under your shirt or towel, it's almost TOO hot. Believe it or not, with the bow cover on, the heat actually stays in the boat for the most part!

Feel free to criticize, compliment, or ask questions.


http://a798.ac-images.myspacecdn.com/images01/21/l_11392e4faa45fbe04bb977a7b70fa11d.jpg
Finished product (what you can see)

http://a875.ac-images.myspacecdn.com/images01/45/l_9a881fbeb53e79504abbdd1bd48433ca.jpg
Front two HotTubes

http://a908.ac-images.myspacecdn.com/images01/75/l_ea60b3ae7d7ad9c4551c76b8fc8a303b.jpg
Rear two HotTubes (yes, I had to trim the rubber baseboard a tiny bit)

Here's what you can't normally see...

http://a549.ac-images.myspacecdn.com/images01/67/l_99d08ec39b32f21105aef73ea6dae80c.jpg
Unit mounted under drivers side bow seat (opposite factory sub location)

http://a461.ac-images.myspacecdn.com/images01/72/l_3880caecf31bd7d8313c9902e9f0af4c.jpg
No loss of storage space!!!

http://a178.ac-images.myspacecdn.com/images01/4/l_82798cbfa4d6cece0a6813edec8606e1.jpg
Ductwork from unit

http://a625.ac-images.myspacecdn.com/images01/89/l_c4e3ae90fd2b3952320b08ab9de33b28.jpg
Ductwork to front HotTubes

http://a622.ac-images.myspacecdn.com/images01/35/l_c5d612842b7b8224a4435c05fe7c5e45.jpg
One hose ties in at the temperature sending unit.
The other goes to the water pump but I couldn't get a good shot of it.

http://a676.ac-images.myspacecdn.com/images01/19/l_f3604ecf4479ad5168b7be3281297ee3.jpg
I added valves at the engine... just in case!

Thanks for looking,
Chris

csmsk
04-11-2008, 11:14 PM
Thanks for the response.

I didn't buy the complete kit just the basic kit. It didn't come with the heater hose or fittings. I just wanted a better quality hose, and I knew I'd be adding the valves, so I figured I'd get all the fittings where I bought those (Home Depot).

Also, I didn't use the three speed control switch that came with the kit. I had a two way rocker switch in the dash that I wasn't using, so I hooked the heater to that. Now I only have control of "high" and "medium" speed. I thought that if I needed the "slow" speed, I didn't really need it on at all!