PDA

View Full Version : Engine Died (No Power)



bluoval
05-23-2004, 10:24 PM
This past weekend my wife some friends and I were heading out for a day of wakeboarding and skiing. On the way out we were going about 15-18 mph and our boat just DIED. I went into panic and started troubleshooting, to no avail I could not fix it on the water. We got the boat back to the dock and had a mechanic look at it, he said that we were not getting any power to the starter. He could get the engine to turn over by bypassing the ignition, but that is it. We have had a litany of problems with our 04 Mobius for the three months we have had it. We are happy with our boat, but man-o-live I would like to use my boat especially because it was brand new when we bought it. Has anyone else had these types of problems with their boats? I know the old addage about boats, but this is getting to be too much.

BLKOUTLS
05-23-2004, 10:51 PM
bluoval,
Take a second and look at the back of the engine is it a DD Mobius or V drive ? If it is a dd there is a large connector on the back side that is known to come loose at least in 02 vintage and boat would just die as you are going. its about three inches around and is a multipin plug kind of hard to miss. Hope this helps.

chris

morphious
05-24-2004, 03:34 PM
I had a simular problem. I found that one of the plugs that is connected to the circuit board behind the Switches in the dash. The main power came unpluged and stopped the motor and I couldn't do anything. Look under the dash and see if there is any unpluged wires.

noneya
05-24-2004, 05:14 PM
There is also a main breaker mounted behind the observer seat, mine got tripped by accident and I had to reset it.

bluoval
05-25-2004, 10:35 PM
Thanks for the feedback guys, but I have checked all of these things. The reset on the battery was tripped due to a surge in the system somewhere. The connectors behind the dash were also checked, but nothing was found disconnected.