View Full Version : Heater install in my '07 LSV

04-11-2008, 09:42 PM
Hey guys,

A few of you wanted pixs of the heater installation that I did this winter, so I figured I'd throw 'em in here.

The project took me all day on a Saturday (6 hours, lunch, and a little more than a six pack). The total cost for the heater and all the parts came to about $550, but I used some expensive heater hose (GoodYear Hi-miler.... made in the USA!)

It works great! The Hot-tubes pull out about 6 feet. If you tuck one under your shirt or towel, it's almost TOO hot. Believe it or not, with the bow cover on, the heat actually stays in the boat for the most part!

Feel free to criticize, compliment, or ask questions.

Finished product (what you can see)

Front two HotTubes

Rear two HotTubes (yes, I had to trim the rubber baseboard a tiny bit)

Here's what you can't normally see...

Unit mounted under drivers side bow seat (opposite factory sub location)

No loss of storage space!!!

Ductwork from unit

Ductwork to front HotTubes

One hose ties in at the temperature sending unit.
The other goes to the water pump but I couldn't get a good shot of it.

I added valves at the engine... just in case!

Thanks for looking,

04-11-2008, 10:03 PM

Really nice install, thanks for sharing the pics. I plan to do the same (except probably just a two outlet unit) one of these days.

Where did you buy the shut off valves? Other than the valves and blue hose, did everything else come with the kit? Why did you decide not to use the kit hose?

Where did you put the control switch?



04-11-2008, 11:14 PM
Thanks for the response.

I didn't buy the complete kit just the basic kit. It didn't come with the heater hose or fittings. I just wanted a better quality hose, and I knew I'd be adding the valves, so I figured I'd get all the fittings where I bought those (Home Depot).

Also, I didn't use the three speed control switch that came with the kit. I had a two way rocker switch in the dash that I wasn't using, so I hooked the heater to that. Now I only have control of "high" and "medium" speed. I thought that if I needed the "slow" speed, I didn't really need it on at all!

04-11-2008, 11:23 PM
Nice setup. The shutoff valves would have been handy on my boat after my heater core developed a leak. I have the two tube setup and it doesn't seem to have as hot of air that I would like but it does take the bite out of the air. One thing for those installing these heaters is the space needed for the heat tubes so you really have to scope out the space behind the surface your mounting and you have a good picture of that. Thanks for sharing.

02-15-2010, 08:40 PM
Most likely you do, thats where mine go. You might be able to route them up under the gunwales if you want but the panels are easy to get out.

02-16-2010, 12:30 AM
I'd maybe switch where you hot water supply comes from. Maybe t into your exhaust manifolds those always have hot water running out of them.

02-21-2010, 01:28 PM
Hey guys, thanks for the comments on my install. Haven't been here in a while.

Yes, I drilled the 4" holes with a brand new hole saw in reverse. Also I used blue painters masking tape on the fiberglass first to protect the gelcoat from splintering. All four holes came out perfectly clean.

Yes, this is a Heatercraft unit.

Yes, I routed the heater hose under the floor, and it was a fairly easy install after hours of planning and preparation.

And Yes, the entire clan of friends and family greatly appreciate my efforts to keep everyone comfortable. Not exactly a challenge here in Northern Cali, but we all love the morning/evening heater sessions nonetheless!!!

Happy Springtime Upgrading to you all!