Results 1 to 10 of 14

Hybrid View

  1. #1
    Join Date
    Oct 2009
    Location
    Tumwater, WA
    Posts
    133

    Default I had to redo most of the stereo

    I didnt like how my amps were mounted. There were already under the passenger seat when I bought the boat so I added more amps then I got scared they would get wet.


    So I listed to everyone on the board and moved them to a rack and behind the wall.....Then decided to add A new deck, sirius radio, and 2 remotes.

    hard to get this thing back there!!!!





  2. #2
    Join Date
    Oct 2009
    Location
    Tumwater, WA
    Posts
    133

    Default






  3. #3
    Join Date
    Mar 2008
    Location
    Vancouver WA
    Posts
    2,623

    Default

    Wow Nice work getting that amp rack back there! Thats a tight sob in there.
    Looks good! How do you like the Alpine stuff so far?


    PWI as usual...

  4. #4
    Join Date
    Oct 2009
    Location
    Tumwater, WA
    Posts
    133

    Default

    I love it. That deck is perfect, I would recommend it to anyone. The volume button on the remotes are a little sensitive, but just something to get used to. That kenwood remote wouldn't work half of the time so its way nicer than that stock garbage.

  5. #5
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,139

    Default

    looks good and MUCH better than where it was. that should extend the life of the amps greatly
    '06 Supra Launch 20SSV-gone but never forgotten

  6. #6
    Join Date
    Oct 2009
    Location
    Wisconsin
    Posts
    330

    Default

    Well done! Not an easy task, I just put my amps there as well. Looks very nice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •