Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2004
    Posts
    2

    Default lsv loosing power

    I have a 2002 LSV with the Indmar 310 with a carburetor. I have 180 hrs on the engine. My problem is a large loss of power. I can notice it in all conditions, but it stands out with a loaded boat. The engine used to perform great with a loaded boat, but now it struggles to get on plan. Any ideas were to start?

    Oh yeh, I have had oil changes around every 50 hrs, but I have not changed the spark plugs. This is one place I was going to start.

    Thanks!

  2. #2
    Join Date
    Apr 2003
    Location
    Powhatan, VA
    Posts
    316

    Default Replying to Topic 'lsv loosing power'

    First think I'd do is change the fuel filter.
    Have had a lot of chevy V8's be starved for fuel and perform poorly due to that problem. And have a second spare on-hand. If your gas is dirty enough to clog the first one, you will likely need more until the problem is eliminated.

    Check cap and rotor for moisture.

    Some of these indmars apparently have a protection mode. If they overheat, I think, an electronic governer of sorts kicks in and only allows you to putter back to the dock. Probably not your problem

    Am assuming you've not screwed around with the plug wires much, ie, that they are seated on the plugs ( with a little dielectric grease ) and are not nicked. If a chevy V8 has nicked wires, they will arc-out under load and loose power. Probably not your issue, but thought I'd mention it.

    Otherwise... not sure what could be deeper wrong....hope its the filter or cap.

  3. #3
    Join Date
    Jul 2004
    Posts
    2

    Default Replying to Topic 'lsv loosing power'

    Thanks for the tips. I have recently changed the fuel filter and last night changed the plugs. Those things looked bad. I'm hopping that was the problem, but I will check the cap and rotor. That was a new one to me. Thanks again for your time.

  4. #4
    Join Date
    Aug 2002
    Location
    Bismarck, NorthDakota
    Posts
    576

    Default Replying to Topic 'lsv loosing power'

    Check your gas for water. Look in the carb for any sign of mostiure.

    I have had this happen twice, bad gas from a station.
    Bruce Fuerstenberg

    Life's journey is not to arrive at the grave safely in a well preserved body, but rather to skid in sideways, totally worn out, shouting...holy shit!...what a ride!

  5. #5
    Join Date
    Sep 2004
    Posts
    7

    Default Replying to Topic 'lsv loosing power'

    another place to check is the conical filters in your carburator. the 99 mobius only came with one fuel filter. There is no in-line fuel filter. With such a large Carb, it can sometimes starve itself after a couple of seconds after you give it a boost of throttle. Take the primary and secondary fuel hoses off the carb and toss (do not replace) the brass colored conical filters. I would then buy a $2 in-line filter from any parts store and install it between the fuel,water separator and the carb.

Similar Threads

  1. 07 XLV or LSV....Enough power?
    By av8r in forum Sales & Information
    Replies: 3
    Last Post: 11-05-2006, 03:28 PM
  2. Pulling Power
    By Longshore in forum Boat Owners
    Replies: 15
    Last Post: 08-05-2006, 10:17 AM
  3. Front Ballast Loosing Water
    By 05mobiusxlv in forum Service & Repair
    Replies: 5
    Last Post: 07-31-2006, 11:35 PM
  4. Power hungry
    By MoombaRob in forum General Chat
    Replies: 3
    Last Post: 05-30-2006, 09:24 PM
  5. battery power
    By pullmyfingers in forum General Chat
    Replies: 6
    Last Post: 03-02-2005, 11:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •