Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2009
    Location
    port washington, ohio
    Posts
    647

    Default cabin speaker help

    ok while surfing my cousin was driving while i was in the water and he took a big roller over the bow turning into the big surf wake instead going the other way. i didn't see how much water came in really but he said he heard a pop then the cabin speakers stopped working. any help where to start looking for my issue?
    08 lsv all red- dual battery system, kicker 700.5 and 450.2 amp, 10" kicker sub, wetsounds eq, polk db651 cabin speakers, exile xm7 tower speakers, ss thru hull fittings, seadek pad, evolutions cover

    http://moomba.com/msgboard/showthread.php?t=10664

  2. #2
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,985

    Default

    check the amp that powers the cabins and see if it shorted out somehow or popped the fuse either on the amp on inline between the amp and battery.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  3. #3
    Join Date
    Jun 2009
    Location
    port washington, ohio
    Posts
    647

    Default

    problem is fixed thanks guys it was a thermal breaker was tripped just took me a while to find what it was
    08 lsv all red- dual battery system, kicker 700.5 and 450.2 amp, 10" kicker sub, wetsounds eq, polk db651 cabin speakers, exile xm7 tower speakers, ss thru hull fittings, seadek pad, evolutions cover

    http://moomba.com/msgboard/showthread.php?t=10664

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •