Results 1 to 9 of 9
  1. #1
    Join Date
    Jun 2009
    Location
    Newberg, Oregon
    Posts
    175

    Default Kenwood Deck and Wired Remotes

    I currently have the Kenwood KTS-MP400MR deck with 2 Kenwood KTS-RC100MR wired remotes that are installed in the factory locations. My deck is starting to crap out on me so I am looking into replacing it. I've looked at the Kenwood KMR-700U and the Kenwood Excelon KDC-X794, both I can pick up for right around $200. The KMR-700u says its is compatiable with the KCA-RC107MR, and the KDC-X794 is compatiable with the KCA-RC60MR. Since my perfect pass controls and drivers wired remote are built around each other I would prefer to not have to replace my wired remotes. I am wondering if anyone knows if the KTS-RC100MR wired remotes that I have are compatiable with either head unit? I emailed Kenwood a couple of weeks ago but never heard back from them.
    Nate

  2. #2
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,202

    Default

    I know for a fact that the 700-u will only work with the remotes for that deck. the factory pucks are not compatible with the 700-u. I can't speak for any other kenwood decks, but if you call their tech support number listed on their website, you will get a person fairly quickly later in the evening. I used it a couple of times when trying to figure out compatibility issues with the deck and pucks. they were very helpful..

    sounds like it's a good time for a custom install??
    '06 Supra Launch 20SSV-gone but never forgotten

  3. #3
    Join Date
    Apr 2010
    Location
    Clarksville, TN
    Posts
    44

    Default

    I have been doing a lot of research IOT replace my Kenwood HU as well. According to everything that I have been reading here on the other threads and in the Crutchfield web site, so long as the HU is steering wheel control capable then the HU will work with the existing Kenwood remotes. You can confirm if the HU is steering wheel remote capable on the Crutchfield site by opening the Kenwood owners manual on the specific HU you are looking at. It will actually show you in the schematic the "rem cont" line (single pin) if it is compatible. Keep in mind that there is a remote power line for power antenna etc as well. I would check to ensure that it is compatible with who ever you buy from just to be sure.
    2006 Moomba OBV-"If you had not committed great sins, God would not have sent a punishment like me upon you".

  4. #4
    Join Date
    Jun 2009
    Location
    Newberg, Oregon
    Posts
    175

    Default

    The KTS-RC100MR that I have do not connect through the "rem cont" connection. They have a dedicated connection in the head unit, that is simular to the CD changer/ipod interface connection point. The same goes for the KCA-RC107MR. I should have looked at that first. The KCA-RC60MR uses the "rem cont" connection. So i am assuming that the 100MR will not work correctly with the X794, unless you are able to connect it through the CD changer port and get them to work that way. Anyone know if this is possible or not?

    I am assuming the the KCA-RC107MR is using the same connection end that the KTS-RC100MR has. Has anyone tried to use the KTS-RC100MR with the 700U?
    Nate

  5. #5
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,202

    Default

    the 107 is the ONLY remote that will work with the 700u. trust me on that one. I, too, spent many hours researching this and ended up on the phone with kenwood for an hour or so.
    do not pay any attention to the "rem cont" wire that is spoken of. there is a special din connection on the rear that the pucks plug into(as you indicated). the old kenwood stuff has like a 6-pin and the new stuff for the 700u has an extra pin in the plug. the 700u stuff actually assigns a "ip address" to each puck.

    iirc, the only decks that you are able to use the 100mr's on are the ktsmp300 and 400 and their replacements..
    the 107 is also a different size than the 100. slightly shorter and taller, and the 2 threaded posts on the back for securing to the boat are off by around 1/8". I had to "massage" one of the mounting holes to get it to surface-mount on the transom.

    if you can get it to fit, the 700u is an outstanding replacement for the older stuff, but if you want to keep the same look and same pucks, the ktsmp400 is a decent deck.


    btw obv6, I used some crutchfield info in making my decision and they stated at the time that the 100 pucks would work with the 700u. imagine my surprise as I was installing the deck and they don't match. $140 later for a new puck and cabling, it worked perfectly don't believe everything you read on their site when it comes to compatibilities.
    again, my advice is to call kenwood if you are looking for some compatabilities that are not of the norm...
    Last edited by sandm; 06-15-2010 at 07:30 PM.
    '06 Supra Launch 20SSV-gone but never forgotten

  6. #6
    Join Date
    Jun 2009
    Location
    Newberg, Oregon
    Posts
    175

    Default

    That sucks that they wont work. Just looks like I am going to be investing in some Alpine equipment instead. I have never liked the quaility or durability of Kenwood products.
    Nate

  7. #7
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,202

    Default

    I can understand your opinions on kenwood, but my experience has been nothing but positive the last few years on their stuff. I have an excelon unit in my truck, going on 2.5 years and not a single issue. old evo had another excelon unit and at a year, same story. the mp400 that came out of my boat is in my sisters tooner and it is still working after 4 years, and the 700u so far(knock on wood) is performing flawlessly.
    alpine makes great stuff as well, but don't discount kenwood. they do have some cheap stuff out there, but who doesn't
    '06 Supra Launch 20SSV-gone but never forgotten

  8. #8
    Join Date
    Jun 2009
    Location
    Newberg, Oregon
    Posts
    175

    Default

    My experience with kenwood is after owning 5 excelon decks. The first was stolen after about a year. 3 of the 5 didn't last longer then 3 months, luckily they were under warranty. Had CD players go out and the RCA connected die as well. The 5, which was the last warranty replacement, lasted almost a year. Once it died I went with Alpine. The 3 years that I had it I had no issues with them other then there weak fm/am tuners. But rarely listen to the radio so I didn't really matter.

    The 400MP has been the longest lasting Kenwood deck I've owned with I lasting a little over 2 years and about 500 hours of use. Only issues I've had with it are that the RCAs are dying. Also have had to replace both remotes in my boat because the LCD screens went out after a year.

    So based on how well Kenwoods products have lasted over the years for me I will not purchase them.
    Nate

  9. #9
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,202

    Default

    sucks. sorry to hear that.
    alpine does make some killer gear. I have had a few of their decks over the years and been very happy with the performance. ergonomics have not been on par with some others, but sound quality was top notch..
    '06 Supra Launch 20SSV-gone but never forgotten

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •