Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2004
    Posts
    20

    Default '04 XLV ballast problem

    Why would the portside, stern ballast bag be filling up when underway without the pump on. is there a main seacock that should be closed, or am I missing something. Your help greatly appreciated. KC

  2. #2
    Join Date
    Feb 2003
    Location
    Maryville, TN
    Posts
    270

    Default Replying to Topic ''04 XLV ballast problem'

    The bag is probably filling because a swicht on a valve has flipped over. The Ballast system fills through one pump and then hits a filter then a manifold system. Each bag has a switch that opens up a valve for water flow. I bet the switch has been flipped on your portside stern bag. Look in your owners manual under ballast sytem and it should show you how to correct the problem.

  3. #3
    Join Date
    Jun 2004
    Posts
    20

    Default Replying to Topic ''04 XLV ballast problem'

    Thanks Jon for the reply...will give it a try.

Similar Threads

  1. Yet Another Problem w/ 07 XLV GG
    By bradcraig78 in forum Service & Repair
    Replies: 5
    Last Post: 05-15-2007, 06:01 PM
  2. don't no my problem do you know
    By chummygyn in forum Service & Repair
    Replies: 1
    Last Post: 04-24-2006, 04:43 PM
  3. 04 LSV Ballast problem
    By tk42 in forum Service & Repair
    Replies: 11
    Last Post: 04-25-2005, 09:00 PM
  4. Skeg problem...
    By jon_n_andrea in forum Service & Repair
    Replies: 3
    Last Post: 02-20-2004, 01:52 PM
  5. problem
    By in forum General Chat
    Replies: 0
    Last Post: 06-30-2003, 06:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •