Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2009
    Location
    wisconsin
    Posts
    1

    Smile adding a wetsounds 420

    anyone have photos of how and where you placed the wetsounds eq., please let me know. currently, exploring options. have the unit in hand. thanks

  2. #2
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    4,170

    Default



    i cleaned the wiring up after this shot was taken. i took two pieces of like 5" x 1" x 1/8" aluminum i bought at home depot and bent L brackets out of them and drilled a series of holes in them. crawled under the dash and found a couple of places in the fiber glass where i could fit a few small screws through the holes in the brackets into the fiber glass. i then placed a block of HDPE plastic between the brackets and screwed that into place, then mounted the WS420 with the brackets it came with to the HPDE. I can get more pictures of it for you when i get home in a couple of weeks
    Last edited by rdlangston13; 04-30-2011 at 10:33 AM.
    David

    2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Harpoon, Exile SM600.1 , Exile Xi800.4.

  3. #3
    Join Date
    Jul 2008
    Location
    Des Moines, IA
    Posts
    2,597

    Default

    Not a wetsounds but...


  4. #4
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,256

    Default

    I still think that install is oh so slick.
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



  5. #5
    Join Date
    Jul 2008
    Location
    Des Moines, IA
    Posts
    2,597

    Default

    Thanks! I'm clearly proud of it since I spam that picture anytime someone even mentions EQ.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •