Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2010
    Location
    Fort Saskatchewan, Alberta
    Posts
    213

    Default Wake Plate "CLICK" through the speakers

    I finally got my Kicker ZXM 700.5 5 channel amp and my new 10" POLK MM1040 Sub installed. I also installed a dual batter system with just the dual battery switch. System is working really well and I love the extra warmth that the sub brings. The only issue I have is a CLICK that feeds through the speakers when I move the wake plate. I have the stereo and amp as well as the + & - busses hooked up to the stereo battery and just the engine hooked up to the other battery. Any suggestions? mabe move the -ve bus to the starter battery?
    2006 Mobius LSV 325 hp MPI Indmar
    2005 6L Silverado 1500HD Quadrasteer
    MODS: Polk DB651's Cabin Speakers, 10" Polk MM1040 Sub in a custom sub box, Kicker ZXM700.5 5 channel Amp, EZ net cargo nets, ACME 1847 Prop, 4 outlet Heatercraft Heater

  2. #2
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    Quote Originally Posted by Grant M View Post
    I finally got my Kicker ZXM 700.5 5 channel amp and my new 10" POLK MM1040 Sub installed. I also installed a dual batter system with just the dual battery switch. System is working really well and I love the extra warmth that the sub brings. The only issue I have is a CLICK that feeds through the speakers when I move the wake plate. I have the stereo and amp as well as the + & - busses hooked up to the stereo battery and just the engine hooked up to the other battery. Any suggestions? mabe move the -ve bus to the starter battery?
    Grant,

    When you say you have the + & 1 busses hooked up to the stereo battery, do you mean the feed that goes to the buss under the dash? If so, that is definitely your problem. Hook up only your stereo and amp pos and neg to the stereo battery and everything else to your starting battery. That will get rid of the clicking noise.

    Al
    Al

    2006 Mobius LSV

  3. #3
    Join Date
    May 2009
    Location
    Dallas, TX
    Posts
    880

    Default

    Grant,
    *First of all, in your particular scheme, which is different than others, nothing but a float switch/bilge pump (if applicable) should go battery direct. The alternator/starter feed, helm buss and ALL audio electronics including source, processor and amplifiers should go to the common (not ground) output post of the dual battery switch. This is precisely how you avoid noise.
    *Make sure that your amplifier input gains are set correctly and not overly sensitive. Setting the gains too hot will NOT increase power but will significantly raise the noise floor and invite the type of noise you have.
    *The quality of grounds and connections are critical including any component in the factory circuit. The batteries to engine block can be a biggie.
    In order to close a supply or ground loop you may have to lift the HU B+ supply and ground off the factory harness and access a point closest to the amplifier primary terminals. Use 14 ga wire for this short run. You may also need to use a better ground on the circuit that controls the wake plate including relays and pump.
    *Oftentimes a separate capacitor can be added to both the 'up' and 'down' output of the switch or relays that control the pump. This will serve to send the considerable AC spike to ground. We have a more sophisticated circuit if the noise is more stubborn.
    *An RCA ground loop isolator can be used between the HU and amplifier as a last ditch effort but this is often a bandaid on a ground loop that still exists. So its better to exhaust all the above remedies first.
    *Rarely is RCA cable positioning a factor as you would have to have a protracted and coincidental path with power wiring which is highly unlikely in your boat.
    *Well charged batteries may help and discharged batteries may hurt.
    *We are talking about a big current draw from halogen lights, I/O trim or wake plates. Sometimes the intensity of the voltage spike or voltage drop is more than the boat system can totally absorb. Other than the engine block there isn't much of a ground mass in a towboat. But if you are thorough and follow the above you will significantly knock it down to a tolerable level.

    David
    Earmark Marine

  4. #4
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    Sorry Grant, David is right - I have a different switch than you.

    I had the exact same problem and I moved the head unit ground wire from the starting battery to the stereo battery and the noise went away. So you might give that a try - run the ground wires for all your stereo related equipment to the stereo battery ground and the helm buss and starter ground to your starting battery. That should get rid of the noise.

    Al
    Al

    2006 Mobius LSV

  5. #5
    Join Date
    Jul 2010
    Location
    Fort Saskatchewan, Alberta
    Posts
    213

    Default

    Al and David thank you so much for the great advice!
    I checked over everything and it was as simple as Al suggested - I simply moved my HU negative wire straight to the battery and voila not more tweeter smashing clicks!!!

    Once again proving how great this forum is and the fantastic folks that choose to help out guys stuck in a jam like me

    Thanks again!

    Grant
    2006 Mobius LSV 325 hp MPI Indmar
    2005 6L Silverado 1500HD Quadrasteer
    MODS: Polk DB651's Cabin Speakers, 10" Polk MM1040 Sub in a custom sub box, Kicker ZXM700.5 5 channel Amp, EZ net cargo nets, ACME 1847 Prop, 4 outlet Heatercraft Heater

  6. #6
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    Quote Originally Posted by Grant M View Post
    Al and David thank you so much for the great advice!
    I checked over everything and it was as simple as Al suggested - I simply moved my HU negative wire straight to the battery and voila not more tweeter smashing clicks!!!

    Once again proving how great this forum is and the fantastic folks that choose to help out guys stuck in a jam like me

    Thanks again!

    Grant
    Glad to help. Don't you just love the easy fixes?? I think it was mmandley who told me this so he deserves the credit. I am just passing it on.

    Al
    Al

    2006 Mobius LSV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •