Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,985

    Default

    08lsv, i have the first pic is exact, but the circut breakers from the 07 to 08 went from the buttons below the switch to the panel like your second pic.

    Thanks for posting.

    zroutt, i would just pull and inspect each fuse in the panel by tracing the wires from the switches. FYI i got my wiring diagram by e-mailing sc acooper@skierschoice.com
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  2. #12
    Join Date
    Jun 2009
    Location
    Sunnyvale, CA
    Posts
    229

    Default

    Quote Originally Posted by jmvotto View Post
    zroutt, i would just pull and inspect each fuse in the panel by tracing the wires from the switches.
    That was going to be my next suggestion... Just pull em all one at a time and see if you find a blown one...
    2008 MOBIUS LSV - Acme 1847, GIII w/1100lbs Vdrive, IBS, PPSG, Wake plate, Z-5, Kenwood 700U, Kenwood Kca-RC107MR , Exile SXT65, Kicker 700.5, Kicker 350.4, Polk MM651, JL 13.5 Thin-Line Sub.

  3. #13
    Join Date
    Jul 2011
    Location
    Rapid City, SD
    Posts
    89

    Default

    I have identified the fuse that trips, I have no issue with that. My problem is when an accessory switch gets turned on while the front ballast is in fill or empty position, then the fuse trips. I will work on following the line from this accessory switch and see what we come up with. That is why I am looking for a wiring diagram. I have no idea what this switch does as it doesn't seem to turn anything on other than the light on the switch.
    2013 Tige RZR w/ConvexVX, WetSounds Rev10s, 6x650s, Syn4 and Syn6 amps.
    Surf Quiver 4x Brigade Wakesurfing Surf Boards- Aviator, Zulu, .352 Special, Bomber
    Victoria Skim 2xGremlins, 2x Agents, 1 Factor, 1 Pixie Bri Chmel Pro Model

  4. #14
    Join Date
    Jun 2009
    Location
    Sunnyvale, CA
    Posts
    229

    Default

    Try to email the address jmv listed about three posts up for the wiring diagram. Maybe they are wired on the same lead... The fuse for the pump is only like 3amps usually, I think so as soon as you add the ACC current draw it may overload the fuse... Just a thought, try using a 5amp fuse in its place and see if they can both run at the same time. Just throwing that out there. It sounds like an odd problem, but they may have just accidentally wired it to the same lead. Hope they can help you get the diagram.
    2008 MOBIUS LSV - Acme 1847, GIII w/1100lbs Vdrive, IBS, PPSG, Wake plate, Z-5, Kenwood 700U, Kenwood Kca-RC107MR , Exile SXT65, Kicker 700.5, Kicker 350.4, Polk MM651, JL 13.5 Thin-Line Sub.

  5. #15
    Join Date
    Jul 2011
    Location
    Rapid City, SD
    Posts
    89

    Default

    Thanks 08LSV. I did already email that address above requesting wiring diagram.

    Also I the fuse that is blowing is a 5amp . Experience tells me not to go up in fuse as it will lead to something else blowing or burning out. Daughter had dance lessons tonight so that took up my evening. Tomorrow after work I am free and will get comfortable under the dash with some tools and play follow that wire.
    2013 Tige RZR w/ConvexVX, WetSounds Rev10s, 6x650s, Syn4 and Syn6 amps.
    Surf Quiver 4x Brigade Wakesurfing Surf Boards- Aviator, Zulu, .352 Special, Bomber
    Victoria Skim 2xGremlins, 2x Agents, 1 Factor, 1 Pixie Bri Chmel Pro Model

  6. #16
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,985

    Default

    zroutt,

    send me your e-mail and i will send the 2005 to 2008 wiring scheme for the giii, it may help you help you outif you don't get the schematics from sc , but they are using pretty quick.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  7. #17
    Join Date
    Aug 2009
    Posts
    6

    Default

    Well, I'll start digging around under the helm. I never thought there could be more fuses for the system, good to know. I'll let you know what I find.

  8. #18
    Join Date
    Jul 2011
    Location
    Rapid City, SD
    Posts
    89

    Default

    Quote Originally Posted by jmvotto View Post
    zroutt,

    send me your e-mail and i will send the 2005 to 2008 wiring scheme for the giii, it may help you help you outif you don't get the schematics from sc , but they are using pretty quick.
    PM sent
    2013 Tige RZR w/ConvexVX, WetSounds Rev10s, 6x650s, Syn4 and Syn6 amps.
    Surf Quiver 4x Brigade Wakesurfing Surf Boards- Aviator, Zulu, .352 Special, Bomber
    Victoria Skim 2xGremlins, 2x Agents, 1 Factor, 1 Pixie Bri Chmel Pro Model

  9. #19
    Join Date
    Aug 2009
    Posts
    6

    Default

    Finally resolved, blown fuse under dash as you guys pointed out. Replaced the fuse blew again when I hit the empty on my right rear ballast. Fill worked fine. Swapped drain pumps to left side and left side fuse blew. I have an order in to replace my drain pump!
    Finally, so happy I tracked it down and was able to resolve this before spending who knows how much at the dealership ($100/hr) to correct the issue. My time is so much cheaper, price of a 12 pack roughly.

  10. #20
    Join Date
    Aug 2009
    Posts
    6

    Default

    Finally resolved, blown fuse under dash as you guys pointed out. Replaced the fuse blew again when I hit the empty on my right rear ballast. Fill worked fine. Swapped drain pumps to left side and left side fuse blew. I have an order in to replace my drain pump!
    Finally, so happy I tracked it down and was able to resolve this before spending who knows how much at the dealership ($100/hr) to correct the issue. My time is so much cheaper, price of a 12 pack roughly.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •