Results 1 to 5 of 5
  1. #1
    Guest

    Default Steering Failure

    Had a big scare after loss of steering in my 1997 Outback with 600 hrs. The Teleflex clamp box located at the aft end of the steering cable became worn out and popped off the metal ball. Suggest removing the 4 bolts on the clamp box that is about the size of a deck of cards and inspect for wear. A new one is easy to replace and about $70 at www.skidim.com

  2. #2
    Join Date
    Aug 2003
    Posts
    10

    Default Steering Failure

    Where is this post? The clamp box failed on by Outback because the ball rubbed out the center of the clamp box.

  3. #3
    Join Date
    Apr 2003
    Location
    Powhatan, VA
    Posts
    316

    Default

    We all need to know more about this steering failure... first time noted on the board that I recall.

    What is the clampbox and what ball are you talking about? Is it the box under the dash? Is the ball on the end of the cable? Is this something weird or do you think it can happen to the rest of us?

  4. #4
    Join Date
    Aug 2003
    Posts
    10

    Default Steering Failure

    The clamp box is under the deck at the stern of the boat aft of the packing nut. It is a black steel box with 4 thru bolts that secure it to the steering cable. A steel ball is bolted to a aluminum plate and the box rotates about the box as the steering wheel is turned. The inside of the box and the outside of the ball rubbed down or ground away so the box could pop off the ball - resulting in no steering at all.

  5. #5
    Join Date
    Apr 2003
    Location
    Powhatan, VA
    Posts
    316

    Default

    Thanks very much. It really helps to hear about what each of us face on these boats as they age a bit.

    I'll remove the floor and take a hard look at the clamp box later this week. Am assuming for now that your '97 and my '99 have same set-up. If so, mine is bound to fail sooner or later. More to follow.

Similar Threads

  1. Steering
    By jon_n_andrea in forum Service & Repair
    Replies: 11
    Last Post: 04-04-2010, 04:20 PM
  2. 07 GG Electrical Failure
    By bradcraig78 in forum Service & Repair
    Replies: 6
    Last Post: 05-03-2007, 03:35 AM
  3. engine failure, wont idle
    By rosh in forum Service & Repair
    Replies: 1
    Last Post: 03-26-2006, 06:06 PM
  4. engine failure, wont idle
    By rosh in forum Service & Repair
    Replies: 0
    Last Post: 03-23-2006, 07:05 PM
  5. Perfect Pass Throttle Failure
    By Shoemaker Mobius in forum Service & Repair
    Replies: 0
    Last Post: 06-16-2004, 03:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •