Page 6 of 7 FirstFirst ... 4567 LastLast
Results 51 to 60 of 67
  1. #51
    Join Date
    Sep 2009
    Location
    newnan, GA
    Posts
    437

    Default

    Every symptom and corresponding codes would indicate a faulty throttle body to me. Take pictures of the throttle body for us so we can see what's going on there. Have stazi translate if need be as I don't speak Spanish

    2005 mobius lsv 2900lbs ballast
    2005 mobius lsv

  2. #52
    Join Date
    May 2011
    Location
    Fort Worth
    Posts
    1,314

    Default

    Quote Originally Posted by superfet View Post
    Hi there.
    I get the same problem if i use the cruisecontrol and don´t turn it off after stoping. Check if cruise control is on and turn it off.
    ^^^^^ we did this when we first got the boat... makes you think all is lost! LOL
    '08 Mobius LS

  3. #53
    Join Date
    Jul 2010
    Posts
    10

    Default

    It's a drive by wire system. It's a 2008. Since this year the tps is attached directly to the throttle handle.

  4. #54
    Join Date
    Jul 2010
    Posts
    10

    Default

    We checked the throttle body and it looked clean, we also opened the Etc and it looked perfect. We found the tps and the cable was bend badly, so we straightened it and moved the connections and the boat performed perfectly for the rest of the day.
    Next day the boat failed again, so Santi and a car electrician disconected the tps and went through the connections. Everything connects Ok.
    Next step would be order a new TPS (I guess...) . I have already contacted Skidim let's see if they have any.
    Is there any way to check the TPS?

    Thanks!
    Last edited by Arek; 08-22-2012 at 12:37 PM. Reason: error

  5. #55
    Join Date
    Jun 2010
    Location
    Lake Houston
    Posts
    656

    Default

    There is a way to check, but you probably don't have access to the software to do it. Go order a new tps and be done with it.
    2013 LSV
    2005 LSV - SOLD

  6. #56
    Join Date
    Aug 2011
    Posts
    170

    Default

    I'm with Lewis. Get a new TPS and be done with it. Also make sure the wires that were bent have continuity to the plug. (I'm thinking this is what you did with the electrician).

    If that's a GM TPS then I bet you can order it online from somewhere like Autozone for dirt cheap rather than getting raped buying it through a European dealer.
    2004 Moomba Mobius LS

  7. #57
    Join Date
    Jun 2010
    Location
    Lake Houston
    Posts
    656

    Default

    Quote Originally Posted by Stazi View Post
    I'm with Lewis. Get a new TPS and be done with it. Also make sure the wires that were bent have continuity to the plug. (I'm thinking this is what you did with the electrician).

    If that's a GM TPS then I bet you can order it online from somewhere like Autozone for dirt cheap rather than getting raped buying it through a European dealer.
    YES YES check the continuity in the wires. I would almost go do that before you buy a new TPS
    2013 LSV
    2005 LSV - SOLD

  8. #58
    Join Date
    Jul 2010
    Posts
    10

    Default

    I think we must check that TPS. Seems like its a part of the teleflex drive by wire throttle system and has to be changed completely.

    http://www.skidim.com/prodinfo.asp?number=108014

    It's the little black potentiometer and the full assembly costs 319$!

  9. #59
    Join Date
    May 2008
    Posts
    23

    Default

    Stazi, Are you sure it's GM (General Motors)?

    I can not find anywhere TPS .... Anyone know where you can buy only the sensor???

  10. #60
    Join Date
    May 2008
    Posts
    23

    Default

    [IMG][/IMG]

    This is the sensor...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •