Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Jan 2006
    Location
    Janesville,Wi
    Posts
    17

    Default adding ws420 to stock 2007 kenwood system

    I have purchased a ws420 for my stock kenwood stereo for my 2007 21v. I am hoping for some installation tips on integrating with the stock system. I have the factory HU(model kts-mp400mr), 4 ch amp, sub, and tower speakers(1 pair). I started the install yesterday and noted the boat speakers(4 of them) are hard wired to the HU(not connected via RCA).

    I want to connect the in boat speakers to the pre-amp for volume control, but I am unsure of the best way to do this. I am satisfied with the in-boat sound(i.e. no amp) for now.

    After connecting everything (except the in boat speakers) to the preamp, I could not get the sub to work, does this have something to do with the way the HU is set up? there is a seperate output on the HU for the sub?

    I know the factory set up is not the best, but I am on a very tight budget, and not much of a audio geek, some may say def-tone even. but I am trying to make the setup more family friendly, and get a little better quality/voume out of the tower speakers.

    if their are inexpensive upgrades I can make to my system, please provide suggestions.

    any recommendations on hooking up in-boat speakers and getting the sub to work are appreciated!

  2. #2
    Join Date
    Jul 2002
    Location
    London Ontario Canada
    Posts
    1,815

    Default

    09 21v LAUNCH

    run your engine after you change your oil
    68 th Member. WS420,HSE Revolution, OJ 466, Acme1157,1100 sacs,Kicker HLCD's n IX500.4, Supra Coolies
    Doug

  3. #3
    Join Date
    Jan 2006
    Location
    Janesville,Wi
    Posts
    17

    Default

    thanks doc!
    I read your post yesterday and it just doesnt answer my questions as you did not have the stock set up I have. as of right now, my boat speakers are not connected to an amp, and also need to get the sub working!

  4. #4
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,489

    Default

    what amp do you have?
    you most likely will not be able to do towers, in boat( cabin and Bow) plus the sub off of one single 4 ch amp.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  5. #5
    Join Date
    Mar 2008
    Location
    Vancouver WA
    Posts
    2,590

    Default

    To utilize all three pre-amps you will need another amplifier for your interiors or tower. Otherwise one or the zones will not be used on the ws420.


    What amp, tower speakers, and sub are you running?


    PWI as usual...

  6. #6
    Join Date
    Jan 2006
    Location
    Janesville,Wi
    Posts
    17

    Default

    stock roswell tower speakers and stock 4 channel kenwood amp, stock sub for 2007 supra

  7. #7
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,489

    Default

    If that cabin speakers are all hooked to the HU, then chanell 1 and 2 are going to the towers and channel 3 & 4 are bridged for the sub.
    you should get the five channle kicker amp zx 700.5 or zxm 700.5 to power the cabins and the sub and utilize the kenwood for the towerd therfore utilizing the seperate control.
    my.02
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  8. #8
    Join Date
    Jan 2006
    Location
    Janesville,Wi
    Posts
    17

    Default

    Well, after troubleshooting the sub/amp/stereo, I found that the sub was actually the problem, it just isn't working anymore.
    Since the sub wasn't working anymore, i just went ahead and bridged the amp for the tower speakers, I think they sound better/louder now then before.
    I will look for a good deal on one of those 5 channel amps, but is that enough considering there are 6 in-boat speakers(4 in the cabin, 2 in the bow). will that power 6 speakers, and a sub(if/when I replace it)?

  9. #9
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,489

    Default

    Yes, that would be perfect. Channel 1 and 2 , bows, 3 and 4 , run in parallel cabin, channel 5 is fr the sub.

    Kenwood is or the towers probably bridged.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  10. #10
    Join Date
    Mar 2008
    Location
    Vancouver WA
    Posts
    2,590

    Default

    The wiring confiureation SC did during that time would almost certainly kill the sub after a year or two.
    They used a dual voice coil sub and would wire one coil to one side of the amp and the other coil to the other. That amp just didn't have enough power, and you always run both channels to a common signal not seperat signals.


    PWI as usual...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •