Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2012
    Location
    St. Albert, Alberta, Canada
    Posts
    169

    Default How do I fix this???

    First day out. I only had the boat for 2 hours last year (has 58 now). Every time I restart the boat it does this then the screen goes blank after about 5 seconds.

    Does anybody know if you can reset the cruise display?
    Unplugging it didn't work.

    ImageUploadedByTapatalk1336962617.573288.jpg

    The funny thing is that the cruise still functions perfect. You just keep pressing the arrows till your at the speed you want. You just don't know what speed that is.

    Any help is appreciated.
    Thanks.


    Sent from my iPhone using Tapatalk
    2010 MOOMBA LSV
    340 CAT
    ACME 1235
    3100#'s




  2. #2
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    6,956

    Default

    Hate to say this, but that looks to me like your screen is shot and I don't think any kind of reset will revive it. Try emailing that pic to SC customer service to see what they say.
    Last edited by wolfeman131; 05-20-2012 at 08:25 AM.
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

  3. #3
    Join Date
    Feb 2012
    Location
    St. Albert, Alberta, Canada
    Posts
    169

    Default

    Could it be a ground or other wiring problem? I was screwing around back there changing the dash lights to LED's this winter and I know it worked last year.


    Sent from my iPhone using Tapatalk
    2010 MOOMBA LSV
    340 CAT
    ACME 1235
    3100#'s




  4. #4
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,135

    Default

    agree with wolfe. looks shot..
    '06 Supra Launch 20SSV-gone but never forgotten

  5. #5
    Join Date
    Mar 2008
    Location
    Vancouver WA
    Posts
    2,609

    Default

    If your handy (and careful) try pulling it apart and make sure the screen is set properly on the circut board. Pretty typical with a digital display thats taken a good hit or drop. Wait until PP says they will not warranty it then try this. The screen is the cheap part so it shouldn't be too bad.
    Good luck man!


    PWI as usual...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •