Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: Loose steering

  1. #21
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    4,100

    Default

    Quote Originally Posted by papou View Post
    Complete steering shaft assembly was just over 200$ here in Canada ,i did the job myself .
    what do you look for to diagnose this? i will be inspecting mine this weekend
    David

    2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Harpoon, Exile SM600.1 , Exile Xi800.4.

  2. #22
    Join Date
    Nov 2009
    Location
    Gatineau, Quebec
    Posts
    129

    Default

    At the end of the steering wheel shaft on the housing you can see and feel the shaft move left or right when you turn the wheel slightly , you can actualy feel it come in and out of contact with the cable gear .i had about 2 inch of slop in the steering
    2012 Mobius LSV
    05 OUTBACK LS FOR SALE

  3. #23
    Join Date
    Jun 2012
    Location
    Spring, TX
    Posts
    44

    Default

    Quote Originally Posted by rdlangston13 View Post
    what do you look for to diagnose this? i will be inspecting mine this weekend
    David did you fix or diagnose your steering? i know have the same 2" slop, mine is also becoming difficult to steer at speed. I read in the owner manual and states lube steering and supposedly there is a grease zerk for the cable but have not looked for it yet.
    2008 22SSV Worlds

  4. #24
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    4,100

    Default Loose steering

    Quote Originally Posted by Worlds22SSV View Post
    David did you fix or diagnose your steering? i know have the same 2" slop, mine is also becoming difficult to steer at speed. I read in the owner manual and states lube steering and supposedly there is a grease zerk for the cable but have not looked for it yet.
    I have not, I won't be around the boat for three weeks but I plan on just buying a new steering box and putting it on next time I am at the lake house. I think the cable is a little more labor intensive and will have to wait till winter


    Sent from my iPhone
    David

    2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Harpoon, Exile SM600.1 , Exile Xi800.4.

  5. #25
    Join Date
    Jun 2008
    Location
    NOR-CAL
    Posts
    178

    Default

    I also had the sloppy issue......
    I think my clamp/block down at the rudder might be sloppy.....But I also found that my wheel had quite a bit of play. I reached under my dash to the bottom of the steering wheel shaft and could feel where it met up with the gearbox. I had a good amount of play before the wheel engaged the gears......I checked around the tilt wheel assembly and found it to be loose. If you pull the black rubber trim piece up from around the back of the wheel you can turn the wheel left or right and there is a set/tightening screw. I tightened that up and it helped. But I noticed some more play yesterday and looked around the clamp block and it seems pretty sloppy. Anyone have any idea how much play should be in that clamp block? I guess the ball joint can wear out?
    07 LSV usually DUMPED

  6. #26
    Join Date
    Jul 2008
    Location
    Des Moines, IA
    Posts
    2,543

    Default

    Quote Originally Posted by Hillbilly View Post
    I also had the sloppy issue......
    I think my clamp/block down at the rudder might be sloppy.....But I also found that my wheel had quite a bit of play. I reached under my dash to the bottom of the steering wheel shaft and could feel where it met up with the gearbox. I had a good amount of play before the wheel engaged the gears......I checked around the tilt wheel assembly and found it to be loose. If you pull the black rubber trim piece up from around the back of the wheel you can turn the wheel left or right and there is a set/tightening screw. I tightened that up and it helped. But I noticed some more play yesterday and looked around the clamp block and it seems pretty sloppy. Anyone have any idea how much play should be in that clamp block? I guess the ball joint can wear out?
    I think this is the same issue I have. My clamp block is a sloppy mess.

  7. #27
    Join Date
    Jul 2011
    Location
    SE MI
    Posts
    128

    Default

    So is mine but I haven't attempted to tighten it because I didn't know if it was supposed to be tight or loose...
    2008 LSV 1100s 650IBS Reversible Pumps w\Timers

  8. #28
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    4,100

    Default Loose steering

    The clamp block is at the rear by the rudder??


    Sent from my iPhone
    David

    2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Harpoon, Exile SM600.1 , Exile Xi800.4.

  9. #29
    Join Date
    Jul 2008
    Location
    Des Moines, IA
    Posts
    2,543

    Default

    Quote Originally Posted by rdlangston13 View Post
    The clamp block is at the rear by the rudder??


    Sent from my iPhone
    Yep just forward of the rudder

  10. #30
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,084

    Default

    Is everybody still dealing with the "sloppy steering" issue? Anybody had success with a fix they tried?
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •