Results 1 to 9 of 9
  1. #1
    Join Date
    Jun 2009
    Location
    Victoria BC Canada
    Posts
    663

    Default Upgraded to Dual Battery system and need your help!

    Hoping someone can help me out. I just upgraded my boat to a dual battey system and everything works except my switches for my nav lights, blower, stereo etc. The boat will turn over and my perfect pass is working but none of the switches will work. I can also see that the distribution block to the amps is getting power as it illuminates and shows 12.6 volts.

    The only thing I can think it would be is that I removed the wires from the original G1 ballast switch thinking that I did not need them any more as I was planning on re wiring this switch for my 4th reversible ballast pump. Is is possible that I screwed something up by doing this?

    I am supposed to be launching the boat tomorrow so if anyone could help me out is would be greatly appreciated.

    Super stressed!

    Wade
    2011 President's Trophy - Check
    2011 Western Confernece Champs - Check
    2011 Stanley Cup Champs - Not so Much....

    2007 Outback V

  2. #2
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,863

    Default

    Wade. Yes sometimes those switches are jumped in series from switch to switch. Try putting it back together may have broken the daisy chain.

    Good luck
    Joe
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  3. #3
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    781

    Default

    I agree with JM. Its very common to find the switches' B+ to daisy-chain from one to the other. Only other thing would be to just double check that a B+ cable feeding a helm fuse/breaker box didnt get left off the during the battery upgrade. A volt meter or 12V test light will come in handy in chasing down the root cause.

  4. #4
    Join Date
    Jun 2009
    Location
    Victoria BC Canada
    Posts
    663

    Default

    Hi guys, good advice but unfortunately I don't remember how they go back on...... Anyone have a wiring diagram for this switch? Shazbot!
    2011 President's Trophy - Check
    2011 Western Confernece Champs - Check
    2011 Stanley Cup Champs - Not so Much....

    2007 Outback V

  5. #5
    Join Date
    Jun 2009
    Location
    Victoria BC Canada
    Posts
    663

    Default

    In case anyone is wondering what the outcome was..... It turns out I had tripped the circuit breaker! Everything is working awesome and my stereo sounds incredible. Long live Exile!
    2011 President's Trophy - Check
    2011 Western Confernece Champs - Check
    2011 Stanley Cup Champs - Not so Much....

    2007 Outback V

  6. #6
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,863

    Default

    the one behind the spotter seat in the cubby?
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  7. #7
    Join Date
    Jun 2009
    Location
    Victoria BC Canada
    Posts
    663

    Default

    Yup. I was having a total panick attack that I screwed something up but it all worked out. I keep meaning to take pictures to show how I managed to get everything to fit an that tiny compartment. I think I spent more time planning the installation than actually installing!
    2011 President's Trophy - Check
    2011 Western Confernece Champs - Check
    2011 Stanley Cup Champs - Not so Much....

    2007 Outback V

  8. #8
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,863

    Default

    yep, that cubby is no bigger than a carryon suit case
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  9. #9
    Join Date
    Oct 2009
    Location
    Pacific NW USA
    Posts
    505

    Default

    Wade - I've regrettably been so busy in the office and in the field I haven't been on the forums much. I this a non issue now? How did your install work out?

    -Brian
    Exile Audio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •