Results 1 to 10 of 12

Hybrid View

  1. #1
    Join Date
    Dec 2006
    Location
    Thomasville, GA
    Posts
    191

    Default Wake Plate Question

    Quick question. I had to replace the upper hinge of one of my actuators on the wake plate about a week ago after it just broke in half. Now the wake plate goes down but stops when it is "level" or when there is no deflection. Bennett trim tabs says those actuators only have an 1 3/8 inch of travel so that is normal and it is going all the way down. I seem to remember it going down further. The pump will stop running when it stops going down but when it goes all the way up the pump will keep running. That doesn't seem to be right either but I really don't remember. Someone with a similar boat please tell me where your plate stops when going down and also what the pump does when the tab goes all the way up and down. Boat is a 2001 Outback DD.

    The gauge also quit working but that is another problem.

    BTW: Just a plug for Bennett Trim Tabs. They have been great and have a really excellent customer service department.
    Last edited by MOOMBA_97; 03-05-2013 at 07:04 PM.
    2001 Outback LS


    " Son, I'm Captain Jack Sparrow "

  2. #2
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,059

    Default

    Can't help with this one but good to hear from you Monty! Glad you're still alive.
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



  3. #3
    Join Date
    Dec 2006
    Location
    Thomasville, GA
    Posts
    191

    Default

    Been a while. Just been busy with family and work going virtual. Until recenty haven't done anything with the boat. I pulled it out of the garage and ran it on the hose for a little while a couple weeks ago. While doing that, the actuator blew out. What it's doing may be normal, just can't remember.

    Nobody knows about this? I'll take any boat with a wake plate.
    2001 Outback LS


    " Son, I'm Captain Jack Sparrow "

  4. #4
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    5,967

    Default

    Monty i cant say for the wake plate pump stopping on the way down. The trim tab should stop when its level with the hull. It might be they put an off switch on the down motion and not the up motion, IDK.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  5. #5
    Join Date
    Aug 2011
    Posts
    948

    Default Re: Wake Plate Question

    The hinge was probably broken allowing the plate to move downwards more..

    Sent from my Nexus 4 using Tapatalk 2
    2002 Moomba Mobius LSV - Sold
    2006 Moomba Mobius LSV

  6. #6
    Join Date
    Sep 2005
    Location
    Claytor Lake, VA
    Posts
    291

    Default

    Plate should travel slightly past level so it creates a hook. My pump stays on as long as I hold the lever up or down and I can hear the sound change when the actuators reach the end of their stroke. They don't have much travel. No switch for up or down, just the coil that drives the gauge. Check you fluid level first. Then try taking the plate loose from the actuators and stroking them.
    2005 Mobius LSV

  7. #7
    Join Date
    Dec 2006
    Location
    Thomasville, GA
    Posts
    191

    Default

    Sounds like they are normal then. They might be going slighty (and I mean slightly) past the hull. I must be losing what little mind I have left. Just got to get the gauge working again. Bennett said to check the ohms on the sensor wire but my ohm meter is broke, go figure.
    2001 Outback LS


    " Son, I'm Captain Jack Sparrow "

  8. #8
    Join Date
    Dec 2006
    Location
    Thomasville, GA
    Posts
    191

    Default

    Update. Fixed the gauge this afternoon. Turned out to be a wire/ground issue. That to all.
    2001 Outback LS


    " Son, I'm Captain Jack Sparrow "

  9. #9
    Join Date
    Sep 2005
    Location
    Claytor Lake, VA
    Posts
    291

    Default

    Glad you got it all working.

    I have to agree about the great service from Bennett.
    2005 Mobius LSV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •