Results 1 to 4 of 4

Hybrid View

  1. #1

    Default 2004 XLV ballast issues. Need Help Please

    I have an 04 XLV with the 3 bag system the front bag switch is located on the driver panel and the 2 rear switches are located on the divider panel between the side hatch and motor box all three are three position switches. Is this a factory setup or where the rear bags added after the fact? Also the sprinkler manifolds were in the open position when I bought the boat I now have them in the closed position & when I last went out the 2 rear bags still filled on their own Why? Also just for info purposes when I lay the divider panel from the engine compartment to the side hatch down the wires to the rear bag switches are not long enough so I know the wires have been pulled off their connector poles previously is their anyway the wires aren't connected properly and this is causing sprinkler manifolds to never be in closed position? If so does anyone have any pix of how switches should be wired? My fill and empty for these bags work properly so I am hoping the wires to sprinkler manifolds are in the wrong positions & when I get them wired correctly system will work.

    Also anyone have issues with trim gauge not working trim tab goes up and down but gauge doesn't read?

  2. #2
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,258

    Default

    I'm gonna guess based on switch positions that original equipment was the "Gravity I" ballast and the rear bags were added later. I have replaced a couple sprinkler valves on a 2008 so I would not be surprised if yours are junk by now. You are right they need to be in the "closed" position. You might want to upgrade the whole system but if you just want to replace sprinkler valves, use the Irritrol ones. They are better stuff and have better flow. I got mine at a local sprinkler sales place but you can get them online too:

    http://www.sprinklerwarehouse.com/Ir...lves-s/433.htm
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



  3. #3
    Join Date
    May 2009
    Location
    Las Vegas, NV & Denver, CO
    Posts
    96

    Default

    I'm headed to pick up my 04 XLV today, I can get you photos of anything you need. I have the Gravity III system.

    also the gauge for the trim, I just had mine replaced its a crappy set up and cheap gauge to be honest, as long as the plate works fine, I would just check the sensor in the pump or the gauge! Let me know what you need??
    2014 Moomba Mojo- Exiled Out!!
    04 XLV- 2 REV 10's & REV410- All JL Audio amps

  4. #4

    Default

    Riding 23 I would like to see the wiring to the back of your rear bag switches to see if mine are on the proper terminals. Also is you Grravity III like mine with the fill & empty switches on the seperator panel between motor and rear drivers side hatch? Also if you could get pix of trim gauge and wiring that would be great thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •