Results 1 to 8 of 8

Hybrid View

  1. #1
    Join Date
    Mar 2013
    Location
    Madison, AL
    Posts
    83

    Question Trim causing speakers to pop

    When we had our boat out we just bought and I messed with the trim while the radio was playing and the speakers poppped everytime i bumped the trim. I have a wet sounds for controlling the tower/cabin/sub speakers. Its all kinda new to me. Any ideas whats causing this? Bad ground possibly?
    2005 Moomba Mobius LSV
    ACME 1433 prop (newest upgrade)
    1900lbs Surf side

  2. #2
    Join Date
    May 2009
    Location
    Dallas, TX
    Posts
    880

    Default

    The cause of the trim control noise will always be present. It's caused by a transient spike from the contacts on the switch or relay that control a high current pump, motor or other device (you can also have it on halogen lamps and other accessories).
    First, you have to make sure that ALL (no exceptions) audio components share the same B+ supply point and share the same ground point with sufficient gauge cables and quality of connectors. That generally means that you will re-wire the source electronics.
    Second, if you still have the noise, which is possible after the first step, you can supress the spike at the switch or relay 'Up' and 'Down' contact poles. You will likely have to suppress both. This most effectively done with a combination capacitor & resistor circuit. A capacitor alone may work.

    David

  3. #3

    Default

    i had the same thing , all i did is run a ground loop icolator on the line in to your amp. i have no noise now

  4. #4
    Join Date
    Mar 2013
    Location
    Madison, AL
    Posts
    83

    Default

    Like for the RCA wires on the amp that powers my tower speakers? or Both amps?
    Like this?
    http://www.amazon.com/Amp-Ground-Loo.../dp/B001JT1F9G
    2005 Moomba Mobius LSV
    ACME 1433 prop (newest upgrade)
    1900lbs Surf side

  5. #5
    Join Date
    May 2009
    Location
    Dallas, TX
    Posts
    880

    Default

    A ground loop isolator is a bandaid that leaves the real problem still intact. It can also alter the sound quality. A ground loop isolator breaks the DC connection between the source electronics and amplification by coupling the RCA ground shield via a transformer. Fix the ground loop first or fix the noise source second and leave the isolator as your final option.

    David

  6. #6
    Join Date
    Nov 2009
    Location
    Stillwater, Oklahoma
    Posts
    318

    Default

    We have found that a pair of non-poplar capacitors placed right at the switch is the best fix. Here is a pic I drew of the fix several years ago.

    Shoot.... I cannot get the file to upload....

    Anyway, we have used the non-polar caps of a 50V 100 uF value. You can use polar caps, but they are harder to find. The 50V 100uF caps are sold by lots of car stereo shops as coaxial speaker bass blockers. David probably has them lying around.

    Your trim switch has 3 wires connected. YOu will have a red or orange wire going in. Then two wires going out. One of the wires going out is Blue/White and the other is Green/White. Using two capacitors, tap into one-each of these two output wires with one of the capacitor leads, and then tie the other two leads of both capacitors to a good ground. One cap will connect between Blue/White and ground and the other cap will connect between Green/White and ground.

    Hope that makes sense. If I could get teh pic to upload it would be obvious, but hopefully my description makes sense.


    David is right, a ground-loop isolator is a bandaid. It masks the problem. Fix the problem and you will not need the bandaid.

    Phil
    Kicker
    Last edited by philwsailz; 05-01-2013 at 01:05 PM.

  7. #7
    Join Date
    Jun 2013
    Posts
    22

    Default Trim causing speakers to pop

    ImageUploadedByTapatalk1371684662.655287.jpg
    ImageUploadedByTapatalk1371684718.604126.jpg
    ImageUploadedByTapatalk1371684735.094011.jpg

    I have 4 wires coming out. Red goes to a 25 amp fuse and then to buss. I bought the 50v 100uf caps. Please help where they go


    Sent via smoke signal using my Zach Morris brick phone.
    '06 Outback V
    325 Assault MPI

  8. #8
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    857

    Default

    Jug,

    Here is a link to a previous post by Phil where he has provided a diag. The easiest place to do this will be under the helm where the wires leave the switch.

    http://www.wakeworld.com/forum/showthread.php?t=745329

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •