Results 1 to 6 of 6
  1. #1
    Join Date
    May 2010
    Location
    Muskoka, Ontario
    Posts
    389

    Default Recommissioning boat in spring from winterization?

    Had our boat done at the local dealer, and want to make sure I don't miss anything putting it all back together in the spring.

    What are the typical connections they normally disconnect that I can check to make sure are put back so when we launch we don't have a leak. I know the majority of hoses to check but I'm not sure where the drain valves are on the engine, and if anything else normally gets taken out that needs to go back in.

    thanks.

  2. #2
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,771

    Default

    Drain plugs, both of mine were out and luckily I checked before launch. Two holes in boat would fill up fast
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  3. #3
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    6,972

    Default Recommissioning boat in spring from winterization?

    If you had your boat winterized at a dealer, they probably pulled at least one of the drain plugs. They do this so winter rains/snow etc don't end up filling the boat with water. I've seen pics of more than 1 and it doesn't look good,
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

  4. #4
    Join Date
    Jul 2012
    Location
    Cumming Ga
    Posts
    303

    Default

    Check all the ballast connections at the manifold and at the bags, make sure the garden hose type connections are tight on the exhaust manifolds, and make sure all plugs are re installed on the block. There is a winterization chat in here, look at that and work backward. I would also make sure you have a new impeller this year and that it isnt leaking

  5. #5
    Join Date
    Aug 2010
    Location
    Acworth, GA
    Posts
    1,219

    Default

    Also check all the coolant hoses by the pump, both sides, where they usually disconnect and drain. I took my boat out first time this season and had water pouring into the bilge while the engine was running. As mine is a VDrive and the engine faces the transom the hoses and water pump are back by the transom. At any rate the passenger side coolant hose had been reconnected but the clamp had been put on crooked which allowed the bottom of the hose to slip off and let the water just pour out into the bilge. A quick grab of the toolkit and a minute later all was well, but i does get the old heart going seeing water rising in the bilge, which I watch by removing the center drain access panel.
    Kraig - 2010 Outback V

  6. #6
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    Go through the winterization thread below and it will show you with pics what to check for.

    http://www.moomba.com/msgboard/showt...ith-pics-by-Al
    Al

    2006 Mobius LSV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •