Page 1 of 3 123 LastLast
Results 1 to 10 of 23
  1. #1
    Join Date
    Jan 2007
    Location
    Hannibal, MO
    Posts
    9

    Default My turn for vapor lock

    Took the boat out today after work for a evening cruise and ran around for a bit with the fam and shut down to float for awhile. It was mid 80's and humid. When I went to start no luck. Looked up vapor lock online and put some cold water on the fuel pump and started it right up. Thank goodness for the iPhone.
    I've read a bunch of old posts on this forum and the supra forum. Just curious what the current best approach is for a 2007 22 ssv with the 325.
    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    3,993

    Default

    '06 20ssv had the same issue. it had the 340, but basically the same motor. I found running the blower during the entire set and letting it run for 5-10 after shutdown cured the issue. even in 110deg heat, I never had the issue again. check your blower/vent hoses as well and make sure they are venting right and not pinched in the engine bay.

    skiers listed a second fuel pump and some other fixes, but the blower trick worked for me and having to replace a blower a few years early is still pretty cheap compared to some other fixes I saw..
    '06 Supra Launch 20SSV-gone but never forgotten

  3. #3
    Join Date
    Jan 2007
    Location
    Hannibal, MO
    Posts
    9

    Default

    This is what SC sent me. Anyone have any notes on changing the fuel filter and checking pressure?
    I am 2 hours from the nearest dealer and I typically do all of my own maintenance.

    I would take the boat your nearest dealer and have them check the fuel system and see the what psi your getting from the pump. They would also need to check your fuel lines and probably replace the fuel filter as it should be replaced every year. Over time fuel with ethanol can start to gum up as most boats sit with the same fuel for several months. Ethanol also reduces the boiling temp of fuel, I believe it is around 130 degrees. When you combine that with clogged filter or deteriorating fuel lines it reduces the boiling temp even more as fuel heats up quicker under more pressure. I hope this helps.

  4. #4
    Join Date
    Sep 2009
    Location
    Austin, TX
    Posts
    144

    Default My turn for vapor lock

    Check your fuel filter first and replace if over a year old. I only had vapor lock once on my 07 and my filter was a bit gunked up
    Skylar18
    2007 Sunsport 22V

  5. #5
    Join Date
    May 2011
    Location
    Fort Worth
    Posts
    1,314

    Default

    Fuel Filter looks like one off a chevy... are there any "marine" differences?
    '08 Mobius LS

  6. #6
    Join Date
    Sep 2009
    Location
    Austin, TX
    Posts
    144

    Default

    I don't believe so, mine come from autozone. I just replace it every year when I do my service. Got a bit lucky, the one time I did get vapor lock, I panicked, called the dealer the next day and he proposed adding a second pump for a few hundred dollars.

    My mechanic at the marina said, check the cheap option first, lets look at your filter! Now change it every year, never had a problem anymore. Maybe I'm lucky but I'm glad I didn't pay for the second pump!
    Skylar18
    2007 Sunsport 22V

  7. #7
    Join Date
    May 2011
    Location
    Fort Worth
    Posts
    1,314

    Default

    Good advise... thanks!
    '08 Mobius LS

  8. #8
    Join Date
    Aug 2008
    Location
    Hilliard, Ohio
    Posts
    329

    Default

    I have found running the blower works well on the 2007 XLV and our current 2006 LSV. One thing that that we also started doing was lifting the engine cover when docked after running the boat. Compared to other boats the air into the engine area is much less on inboard boats.

  9. #9
    Join Date
    Jan 2007
    Location
    Hannibal, MO
    Posts
    9

    Default

    Replaced the fuel filter this morning and then headed out. Did fine while wakeboarding with the blower on non stop between starting and stopping. Stopped for lunch and the problem came back. Dumped water on the fuel pump and all good. I'm starting to think I need to take another step to fix the problem. Anyone have pics of the second fuel pump setup?
    07 22SSV -- Wetsounds!

  10. #10
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    3,993

    Default

    that sucks.

    iirc, it's just an inline pump between tank and fuel filter that is energized when the key is switched on. autozone/napa should be able to recommend a pump that can supply enough flow for a small block chevy motor with efi.. just have to make sure it's rated to get wet. overtons/bakes might have one as well.
    '06 Supra Launch 20SSV-gone but never forgotten

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •