Results 1 to 4 of 4

Hybrid View

  1. #1
    Join Date
    May 2013
    Posts
    1

    Default 99 Mobius Electric Problem

    We took our 1999 Mobius out of winter storage (winterized by professionals) and the boat started and ran just fine. A few days later, the electrics on the dash all worked, but when we tried to start it, the ignition did not engage and all of the power then died. We replaced the battery and encountered the exact same problem: all lights/blower would turn on but when the key was turned to start the engine, all electronics died and the boat would not start.

    Any suggestions on what the problem is and how to solve?

  2. #2
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    7,109

    Default 99 Mobius Electric Problem

    Quote Originally Posted by jdocter View Post
    Any suggestions on what the problem is and how to solve?
    Problem: 14 yr old boat
    How to solve: buy a new boat
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

  3. #3
    Join Date
    Jan 2008
    Location
    Pensacola, FL
    Posts
    1,544

    Default

    I would start with the keyed ignition. It's fairly cheap and easy. Do any of the circuit breakers pop when this happens?
    1997 MasterCraft 205

    2008 Moomba Outback
    1999 MasterCraft Sportstar OB
    1992 MasterCraft 205
    1999 Malibu Response LX
    1987 Marlin Magnum Skier

  4. #4
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,389

    Default

    Yup, and take a good hard look at the battery cables and make sure everything is right.

    Almost sounds like it could be a short at the solenoid too.
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •