Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Join Date
    Jul 2002
    Location
    London Ontario Canada
    Posts
    1,851

    Default

    did you stabilize the fuel last fall and is the throttle in the neutral position, if its in the flooded engine position this will stop fuel from flowing to the injectors.
    09 21v LAUNCH

    run your engine after you change your oil
    68 th Member. WS420,HSE Revolution, OJ 466, Acme1157,1100 sacs,Kicker HLCD's n IX500.4, Supra Coolies
    Doug

  2. #12
    Join Date
    Jan 2008
    Location
    Pensacola, FL
    Posts
    1,544

    Default

    Yes, there is a shrader valve on or near the fuel rail. However, I could not hold the valve and turn ignition on, so I just dropped the hose.
    1997 MasterCraft 205

    2008 Moomba Outback
    1999 MasterCraft Sportstar OB
    1992 MasterCraft 205
    1999 Malibu Response LX
    1987 Marlin Magnum Skier

  3. #13

    Default

    The fuel was supposed to be stabilized last Fall when I had it winterized, and the throttle is in the neutral position. The engine won't turn over if it isn't.

  4. #14

    Default

    Well I've figured out why the engine isn't getting fuel. The 20amp fuse to the fuel pump keeps was blown and when I replaced it, it blew again. Does anyone know why that fuse would be blowing? Also, if anyone has a link to a schematic of the wiring for a 2005 Mobius LSV that would be huge. I'll attach an image of what fuse is blowing.Fuse.jpg
    Last edited by Garland21; 05-26-2013 at 12:51 PM.

  5. #15
    Join Date
    Nov 2009
    Location
    Kaukauna, WI - 3minutes from glass
    Posts
    1,754

    Default Re: 2005 Mobius LSV not getting fuel to the engine

    I had a problem with the wire going to the bottom fuel pump. I bumped it when working on the ballast it would cut in because of bad contact. That would be enough to blow fuses.

    Sent from my SCH-R970 using Tapatalk 2
    -Mark
    14 Mojo - Waiting patiently for my build date.
    02 Mobius LSV ---- Sold and always will be remembered as the one that started it all.

    "Hey you only live once"

  6. #16
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    6,029

    Default

    Fuses blowing is normally due to over current request buy the item its fused with. I would be leaning toward a new pump, its most likely going bad and asking for more then its recommended amperage and this is why the fuse keeps blowing.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  7. #17

    Default

    Ended up taking the boat to the marina, and it was the fuel pump. It had seized up and was causing the fuse to blow. They are letting me purchase the fuel pump myself and will install it for me to save me some cash. Anyone have a good web site to purchase fuel pumps from? I need the INDMAR S556184 fuel pump, and it ain't cheap from what I've found so far...

  8. #18
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    7,054

    Default 2005 Mobius LSV not getting fuel to the engine

    Have you tried skidim?

    http://www.skidim.com/
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •