Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Apr 2013
    Location
    Richmond, VA
    Posts
    2

    Default 2012 GIII ballast percentage full / empty

    The percentage full /empty for the ballast in the digital cruise pro is troublesome (i dont think this is news to anyone here)
    Today my center bag emptied completely, yet the display was showing 97%.
    Next time I fill this bag I will have to toogle the switch on and off every thirty seconds to fill the bag up. Does anyone know how to reset these numbers?
    Shutting the main power off doesnt work.
    2012 outback V with 1200lb G-III

  2. #2
    Join Date
    Jan 2012
    Location
    Lay lake Alabama
    Posts
    12

    Default 2012 GIII ballast percentage full / empty

    Good question. I sometimes have the same problem. I'm curious also.
    2012 lsv, 330 indmar, oz tower, gravity III, 1100 surf side, acme 537, kicker kmt6 tower speakers, 6 alpine 7"s in cabin, 2 Sony 12's, wetsounds ws420, 3 amps.
    Sold 2007 outback

  3. #3
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    5,617

    Default

    You cant reset the number but you can go to the timers and change the timer TIME to 1 minute, this when you click the switch on it should goto 0 in that same minute.

    I agree with the timer system, its one of the new features i really hate, i honestly would rather have to be concerned with burning up impellers then dealing with the timers.

    I have since set my timers to 20 minutes, and i dont worry so much about the % anymore. As long as im paying attention to draining there wont be any issues.

    The factory hard tank how ever should be set to 5 minutes apx
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  4. #4
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,489

    Default

    here is a good How to video from WM

    http://www.youtube.com/watch?v=0b0Q1dhRqBU
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  5. #5
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    6,753

    Default

    On the 2012 & 2013 boats, if the gauge reads 0% with a full bag you will just need to cycle the switch on and off until the bag gets down to empty. I know it’s a pain but it’s the only way.

    If the gauge reads 100% with an empty bag, you can use Mike's trick or trip the breaker to the rear PDM. This is located in the engine compartment mounted on the port side wall. You can then turn the switch to empty and the gauge will run down but the pumps will not run.
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

  6. #6
    Join Date
    Jun 2007
    Location
    Richmond, TX
    Posts
    447

    Default

    I have a 2010 and the % always shows 0, whether full or empty. Does anyone know how to get it to work? In addition to that, the temp always shows the air temp. I thought it was supposed to be the water temp?
    Current: 2010 LSV
    Previous: 2007 Outback

  7. #7
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    5,617

    Default

    Quote Originally Posted by TL7 View Post
    I have a 2010 and the % always shows 0, whether full or empty. Does anyone know how to get it to work? In addition to that, the temp always shows the air temp. I thought it was supposed to be the water temp?
    Interesting, have you gone into the settings screen on the dash to see what the timer set point is? Im wondering if yours is the first year they had the display but still used the switching method for timers.

    Air temp? I dont think mine has air temp, only water temp
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  8. #8
    Join Date
    Jun 2007
    Location
    Richmond, TX
    Posts
    447

    Default

    That's my point - it displays a temp, but the temp is the air temp rather than the water temp. I've went through just about every setting I could find. The boat came with EZ Cruise, and I bought the Digital Cruise about a year or so ago through Heidi. It was a simple plug and play, but maybe there is a conflict because of the difference in years?
    Current: 2010 LSV
    Previous: 2007 Outback

  9. #9
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    6,753

    Default

    flip the boat over & maybe you'll get it to read water temp
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

  10. #10
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    5,617

    Default

    Quote Originally Posted by TL7 View Post
    That's my point - it displays a temp, but the temp is the air temp rather than the water temp. I've went through just about every setting I could find. The boat came with EZ Cruise, and I bought the Digital Cruise about a year or so ago through Heidi. It was a simple plug and play, but maybe there is a conflict because of the difference in years?
    My second thought on this is,
    With you buying the unit after, and having digitial cruise now, the water temp is taken at the paddel wheel, it has a built in sensor so i dont understand why it wouldnt read the water temp.

    The 0% i have a feeling comes from the timer control modules so you may not have that due to having the older switch based timer. It might be as simple as figuring out what lead on your connector is for the % indicator, as this is strickly a Motor ON timer to create the %. Not positive just my out loud thinking here.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •