Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    5,615

    Default

    On the Rare occasion you have issues with reaching someone, let me know i am more then happy to Expidite anything you need.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  2. #12
    Join Date
    Mar 2010
    Location
    Irondequoit Bay, NY
    Posts
    1,096

    Default

    Quote Originally Posted by mmandley View Post
    On the Rare occasion you have issues with reaching someone, let me know i am more then happy to Expidite anything you need.
    true..i was talking to mike and he would talk to natlie for me as well and it also helped out
    2004 Outback Blue/white w/5.7 indmar 350, Direct Drive
    Rockford fasgate cabins
    Rockford fasgate 500w amp (cabin) and a kenwood HU (kmr700u)
    Exile XM7's
    Exile Harpoon
    Exile ZLD
    Polk 10in sub (2)
    Polk P330 amp (subs)

  3. #13
    Join Date
    Mar 2010
    Location
    Irondequoit Bay, NY
    Posts
    1,096

    Default

    got my parts in today from brian and his team..after work tonight (1130pm) ill head home and install it again and hope for the best haha..plan on putting them to the test this weekend..plan on going out to the cove and then meeting up with a friend whos got a 40' fountain(maybe i can talk them into getting cabin speakers haha)
    2004 Outback Blue/white w/5.7 indmar 350, Direct Drive
    Rockford fasgate cabins
    Rockford fasgate 500w amp (cabin) and a kenwood HU (kmr700u)
    Exile XM7's
    Exile Harpoon
    Exile ZLD
    Polk 10in sub (2)
    Polk P330 amp (subs)

  4. #14
    Join Date
    Oct 2009
    Location
    Pacific NW USA
    Posts
    488

    Default

    Just kind of stumbled upon this thread and have to say all the comments made my week. I haven't been on the board in weeks. It's just plain insanely busy at the office. We do our best to take care of people no matter what. Moto's situation was unfortunate that he bought someone else's problem, but ultimately the buck stops here.

    There was a time when I had direct involvement with most of the customers and honestly thats not the case these days. However, the people that work at the company understand clearly what my expectations are and work very hard to get it right, "no matter what". We dont always get it right... but we try.

    Thanks for the support

    -Brian

  5. #15
    Join Date
    Mar 2011
    Location
    Houston, TX
    Posts
    235

    Default

    I'd like to clarify some things here. I sold the amp to motosno963 but I feel some details here are misrepresented. I am in agreement that the Exile customer service is excellent as Brian sent me 800.4s to attempt to resolve my Harpoon overheating issue (unfortunately these didn't solve the issue; I believe that the amplifier efficiency is the issue when exposed to Texas heat). I absolutely oppose the assertion that I sold him a faulty amplifier as the Harpoon was installed in my boat and working weekly when I removed it last June. It would only overheat during prolonged periods of high output in the cove when it was ~100 degrees. It would go into protection mode, cool down, and then we would use it the rest of the day. Never a functional issue, only the amp occasionally protecting itself from overheating damage. Since then, it has been stored in my air conditioned closet until shipped to him about a month ago. I also disclosed this same information during the sales dialogue and genuinely believe the amp will perform well under his area's weather conditions.

    Regarding the warranty claim, I never knew that Exile classified it as warranty nor did they request that I send the amplifier back. Considering it had just been lying around, I posted it and sold it when I was selling some other electronics I wasn't using anymore. I'm sorry that motosno963 was having issues with it but the amp was in operating fine when it was shipped.

    My intent isn't to spurn an argument here but just felt compelled to provide the facts from my perspective.
    2007 Mobius LSV
    Boat Pic

  6. #16
    Join Date
    Mar 2010
    Location
    Irondequoit Bay, NY
    Posts
    1,096

    Default

    its all good..it worked once for me then nothing after so i told brian and he said to send it back, so thats what i did.. nothing against you, just doing what i was told. but now that i have the new harpoon its working great
    2004 Outback Blue/white w/5.7 indmar 350, Direct Drive
    Rockford fasgate cabins
    Rockford fasgate 500w amp (cabin) and a kenwood HU (kmr700u)
    Exile XM7's
    Exile Harpoon
    Exile ZLD
    Polk 10in sub (2)
    Polk P330 amp (subs)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •