I was at Lake Powell over the 4th of
July and the first day on the lake I launched from Antelope point and
drove hard up to the very end of Navajo Canyon and it was about 109F
outside. So once we made it to the end of the canyon, I shut the boat
off and we were floating around swimming and having a beer. When it
came time to move the boat because we were floating near some rocks,
the Moomba wouldn't start. It had the symptoms of Vapor Lock; so I
put a wet towel over the fuel pump and poured cool water over it;
30-40 minutes later it started up. It did this the rest of the day.
Once we made it back to the rental
place my buddies and I (all engineers) were looking at how the fuel
pump is installed and designed. It's nothing like a car or jeep.
Trying to see why this happens and how we can fix this problem from
occurring again (problem solving) and in the process we noticed at
the very bottom of the fuel pump was an oil line/hose resting against
the bottom of the fuel pump and this oil line was still very hot
after sitting for a few hours. This oil would have to be in the
180-200F temperature while running which would drive the temperature
of the fuel pump up via conductive heating. So I zipped tied up the
oil line that was lying against the fuel pump so there was about 2"
of air gap between the fuel pump and the hot oil line.
I ran the boat for two more days (same
outside temperature) pretty hard for many hours and every time I
stopped; I would open up the motor compartment and I felt the fuel
pump, it was cool to the touch and I did not have the vapor lock
issue any more. So for those of you that are having vapor lock
issues, I would recommend looking at your fuel pump and make sure
that you don't have any oil lines touching or rubbing against your
fuel pump. My next plan is to dress up the oil lines with some clamps
which will be more reliable than the zip ties which were a quick fix.

I hope this helps