Results 1 to 4 of 4

Hybrid View

  1. #1
    Join Date
    Jul 2009
    Location
    Cleveland, Tn
    Posts
    258

    Default Court light switch issue

    I have an electrical question. Very limited knowledge on electrical things.

    2 weeks ago my court light switch went out. No light on switch or court lights. I have checked the connections in the back of the switch. My inboat LEDs are tied to this switch using jumpers off court switch wires and are also out. So I know that there is no power coming in...at least I thinks so.

    Can someone give me a list of things to check? Is there a circuit breaker that I'm missing just for this switch?

    All other boat switches working fine.
    2012 Mojo
    2009 LS (SOLD!!!)
    2010 Tundra 5.7 Crewmax 4X4

  2. #2
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    6,043

    Default

    Quote Originally Posted by Salyers View Post
    I have an electrical question. Very limited knowledge on electrical things.

    2 weeks ago my court light switch went out. No light on switch or court lights. I have checked the connections in the back of the switch. My inboat LEDs are tied to this switch using jumpers off court switch wires and are also out. So I know that there is no power coming in...at least I thinks so.

    Can someone give me a list of things to check? Is there a circuit breaker that I'm missing just for this switch?

    All other boat switches working fine.
    There should be a set of circuit breakers under the dash, they have a some what clear plastic cover and the white button on the breaker.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  3. #3
    Join Date
    Jul 2009
    Location
    Cleveland, Tn
    Posts
    258

    Default

    Thanks! I'll check tonight!
    2012 Mojo
    2009 LS (SOLD!!!)
    2010 Tundra 5.7 Crewmax 4X4

  4. #4
    Join Date
    Jul 2009
    Location
    Cleveland, Tn
    Posts
    258

    Default

    Breaker reset! Problem solved! Thanks!
    2012 Mojo
    2009 LS (SOLD!!!)
    2010 Tundra 5.7 Crewmax 4X4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •