Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2012
    Posts
    2

    Default Blower motor help

    Got a 02 outback, blower motor went out in. Pulled the back cover an it's got 2 vent hoses but only 1 motor. Is that right or does it need 2 motors? Bought the boat used so didn't know if it needed another. Also how far up the floor should the vent hoses go? 1 with the motor attached goes under floor, there's a PVC pipe there but it's not attached to the flex pipe should it be? The other flex line just vents in the rear compartment, is this the way it's suppose to be? Anyone know?

  2. #2
    Join Date
    Dec 2006
    Location
    Tuscaloosa, Alabama
    Posts
    736

    Default

    You will only have one motor. The rest are just vent hoses
    Jack Beams
    '05 Outback DD
    325HP EFI Indmar

  3. #3
    Join Date
    Aug 2012
    Posts
    2

    Default

    Does the vent hose need to run up to the engine area? From the blower mine just goes to floor and stops, there's a PVC pipe there that goes to engine area that looks like flex hose should be attached to, but its not.

  4. #4
    Join Date
    Nov 2003
    Location
    Land O Lakes, Florida
    Posts
    5,870

    Default

    your blower motor should be attached with a slinky looking black hose that should be attached to the vent
    Hey, Its Moomba time

    13 Mobius LSV
    08 Mobius LSV-sold
    03 Mobius LSV-sold
    life is about finding the balance between being a responsible adult and staying young at heart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •