Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2011
    Posts
    18

    Default Check Engine Light

    I recently purchased an 07 LSV after having an 05 LS for several years.I noticed yesterday the check engine light is o for some reason. The oil level is great as the oil was recently changed. Is there some type of oil reset? Is there any other things to check? I just want to be careful and not mess anything up. Any help would be appreciated.

  2. #2
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,830

    Default

    Check engine will be on with a v drive until your rpms get about 1000 or 1500 I think.

    If not you could have had a battery charge issue, which it should recycle after 3 to 4 cold restarts.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  3. #3
    Join Date
    Jun 2012
    Location
    Lake Amistad, TX
    Posts
    562

    Default Check Engine Light

    Yea it's normal. Mine comes on as soon as I start the boat, goes away as I accelerate, then comes back on when back at idle!
    2004 Outback Blue on White *Sold
    2008 LSV Blue on White
    EXILED with 6 SX65-M in cabin & 2 XM9s rockin the tower
    2 Kicker ZX700.5 Amps powering the entire boat with 2 10" Subs under the dash
    Krypt KMA4200 EQ under driver's side dash to control all the madness
    Z5 Cargo Rack annnnnnnd She's NEKKKKED....

    I'm no expert, I just read up on the Moomba Forum...

  4. #4
    Join Date
    Apr 2013
    Location
    DFW
    Posts
    55

    Default Check Engine Light

    Quote Originally Posted by tgoody14 View Post
    Yea it's normal. Mine comes on as soon as I start the boat, goes away as I accelerate, then comes back on when back at idle!
    Check engine or check v drive. My v drive light works this way, but not engine. Could be a difference in year models though.


    Sent from my iPhone using Tapatalk 2
    Matt
    2012 LSV

  5. #5
    Join Date
    Jun 2012
    Location
    Lake Amistad, TX
    Posts
    562

    Default Check Engine Light

    Ohh yea, sorry I'm still waking up! I'm referring to the V-drive light I believe, the one below the throttle! My bad, getting more coffee now haha
    2004 Outback Blue on White *Sold
    2008 LSV Blue on White
    EXILED with 6 SX65-M in cabin & 2 XM9s rockin the tower
    2 Kicker ZX700.5 Amps powering the entire boat with 2 10" Subs under the dash
    Krypt KMA4200 EQ under driver's side dash to control all the madness
    Z5 Cargo Rack annnnnnnd She's NEKKKKED....

    I'm no expert, I just read up on the Moomba Forum...

  6. #6
    Join Date
    Jul 2011
    Posts
    18

    Default

    Thanks guys for all the help. The light is no longer on after like 6 cranks after installing the new batteries.

  7. #7
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,830

    Default

    Good you got it figured out, low batt voltage can do that.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •